Object viewport issue

Hi, does anybody know how I’ve managed to set the ice cubes to be visible from the side view (poking out the top) but from the top view you can’t see them?

They weren’t always like this but I can’t seem to figure out what I’ve done. It is only in the viewport, they render as they should.

It’s driving me mad, I know it must be something really obvious!

Thanks,
Pete

It’s okay, I think it was that I had somehow ticked ‘In Front’ on this objects Viewport Settings.