Objects deforming when parenting to bones

Hi, I recently just started to get into blender, and have been doing pretty good. But when I started rigging, i came to a dead end. I made a simple ‘block guy’ kind of character, with all the parts made from cubes. I was able to make an armature that went through the body and the limbs, but when I parented the, for example, left leg to the ‘left leg’ bone, it deformed the leg, and I think I figured out that the child takes on the parent’s scale. When the leg was remade, I use an inverse kinematics constraint on it. But when I tested it by moving the bone, the leg deformed into a trapezoid-like shape. I tried looking everywhere for a fix, but couldn’t find one. In a couple of rigging tutorials I watched the objects didn’t even change one bit when parented to bones. Is it the way I’m shaping and placing the cubes in the first place? Any help would be greatly appreciated.

Please post your blend file, or at least some pictures of the problem. We cannot possibly offer any help from just a description as you have posted it. There are probably no where near enough vertices in a cube to achieve any kind of viable animation, other than a purely mechanical one. Have you fixed any rotation or scaling on the meshes using CTRL-A?, etc. etc. How did you parent the meshes to the armature? There are too many questions we could ask you.

Oh yes, welcome to BA!

Cheers, Clock.

Block Guy.blend (487 KB)

This is what I have. And yes, since I’m just a beginner, I wanted simple, rigid movement. I parented it by selecting the parent under the Relations tab under Object. I notice that ctrl+A is Apply, which I have not seen before. Is it used to apply an objects scale to another?

To parent a mesh to an armature, first select the mesh, then Shift+select the armature, then press CTRL-P and choose either “Automatic Weights” or “With Empty Groups”, in the latter case, then assign the required vertices to the required bone in the Vertex Groups Section in Edit Mode. Remove the parent you have setup first.

CTRL-A is used to “zero” the scale or rotation of the SELECTED object, setting all values back to 0. You should ideally NOT rotate or scale meshes in Object mode, rather do the scaling or rotating of the vertices in Edit mode. If you Apply the location, the mesh will be moved to 0,0,0 (blend file centre).

It’s getting late here , so I will look at your blend file tomorrow.

In the meantime you should read this tutorial:


Cheers, Clock.

PS. Your post will take some time to get on here as you will be moderated until you have made 10 meaningful posts, just so you know why there is a delay to your post being seen.

Just had a quick look - you have scaled your armature by a factor of 8 in the Z axis only - therein lies your problems! Don’t do this! Select your armature in Object Mode and press CTRL-A then select “Scale” - that should help you.

More later, Clock.

I just remade it, extruding the cubes in Edit mode. Something didn’t seem right using Scale hahaha. I’m coming from an AutoCad background, so some of the controls don’t make sense. But I was able to successfully rig the block guy using automatic weights, and made a simple walking animation. Thanks for the help!

Glad to help!

Rules to observe when learning Blender:

  1. Don’t scale or rotate objects in Object Mode, unless you then apply the rotation or scale. If you must scale them, do this to the vertices in Edit Mode - this will cause you less problems.

  2. Don’t scale an armature in Object Mode, particularly in one axis only, unless you then apply the scale. Go to Edit Mode for the armature and drag the head or tail of the bone to where you want it.

  3. Forget all your AutoCAD techniques other than the understanding of 3 Dimensional Space!

  4. Sub-Division Modifier is your best friend for modelling - learn how to use it!

I trust you found the Gus tutorial useful, it is a very good starting point for Blender modelling and animation.

Have fun, Cheers, Clock.