Objects not included in render layer are affecting objects in render layer

Hi all, needing a bit of help on this one…

I’m having problems with a mesh object that isn’t included in a render layer affecting objects in the render layer. I’ve removed everything that isn’t needed to show the problems I’m having.

Basically what I have is a cube on 2 object layers, camera & lights on another object layer, and a plane to receive shadows on another object layer. The cube has a reflective material on it. I’ve setup 2 render layers, the first render layer - called ‘ForeGroundLayer’ - includes the cube, the lights & camera. The 2nd render layer - called ‘ShadowLayer’ - includes the cube, the lights & camera, & the shadow plane. The shadow plane isn’t in the ‘ForeGroundLayer’ render layer, but yet it’s reflection is appearing in the cube and I’m not understanding why.

My thinking was render the cube, camera & lights in one render layer, so the shadow plane doesn’t reflect on the cube. At the same time render the cube, camera & lights, & the shadow plane, then combine both render layers so the ‘ForeGroundLayer’ - (without the shadow plane & it reflection) on top of the ‘ShadowLayer’ so the reflections of the shadow plane wouldn’t be visible in the cube.

I could just render out the cube, camera & lights layers as an image sequence, then render out the cube, camera & lights, & shadow plane as another image sequence, then composite them, but that seems like too much when as I understand it, using render layers should do provide me with what I want in one rendering of the scene.

I admit, I’m don’t know alot about render layers, but it just seems odd that an object not included in a render layer is affecting objects in that render layer…

I’d appreciate it if someone could look at the attached .blend file and tell me what I am doing wrong.



shadow_test.blend (782 KB)

I’m not sure exactly what result you’re looking for, but if you turn off Options ->Traceable in the shadow plane’s material, it shouldn’t reflect in the cube. Then you can composite the foreground and the shadow together. You can remove the foreground scene layers from the “Shadow” renderlayer.

Thanks CD38, that was exactly what I was after. Yes, it might have seemed confusing the way I had the render layers setup, I’m a little rusty in that area and the manual isn’t much help.

Thanks again,