Objects not showing in rendering

I know I’m not the first one to ask this question. I read many, too many posts and tutorials on the subject, try every solution I could, but my problem is still isn’t solved. I can’t see my animated object in rendering mode. When I press 0 on the num pad, my object is there, right in front of the camera, but there’s nothing except the grid in rendering mode. I thought it might be a computer problem (it’s a little limit on some specs, I’m waiting the new one) so I reboot it to no avail. I’m not even able to see the cube in rendering mode when opening Blender on a fresh new page (but I’m pretty sure I could the first time around). What am I doing wrong? I’m using 3.0 version btw.

Thanks in advance for all help you can provide!

P.S.: I’m new to Blender (1 week) so explain in details like if I was 3…

Some thoughts:

  1. Check if the camera symbol is checked for your objects here:

  2. If you are using Cycles for rendering, make sure these are checked for every object:

  3. There may be some systems settings you need to play around with:

  4. Try switching from GPU to CPU rendering or vice versa:
    image

Thank you so much LordoftheFleas for your clear answer, perfect for a newbie like me.

The problem probably comes from my computer. I don’t have a real graphic card, only the one included with my i5-8400. That must be the problem. I’ve been able to see in rendering when I began, but it seems that my computer doesn’t want anymore. I don’t see the Ray visibility part though. So maybe there’s a problem there too. All the other settings seem fine.

I should have my i7-12700 with a 3070 graphic card this week (but it’s been 3 weeks that it’s supposed to be ‘this week’). I will let you know when I’ll work with the new one if it works better, unless you have another tip for me to solve my graphic card problem.

Thanks again for your help!

I just found the ray visibility (I noticed I had the cube selected instead of the light) but it’s fine on that side too so the problem really comes from my computer.

These settings only appear when the renderer is set to “Cylces” (but this probably won’t solve your issue):
image

I will have to wait for my new computer. Meanwhile, I learned a lot of Blender features with this issue. Everything can’t be bad! Thanks again!

1 Like

may be worth a shot, what shows up when you select “none” for your render devices, and then select “CPU” under “device” for your render settings?

You will have to explain me where to go to find the ‘render devices’. As I said, I’m a newbie on Blender and I’m still stuggling to find where everything is!

Yes, that part is fine, it’s after that I don’t know where to go [quote=“Jakebane, post:7, topic:1351536”]
and then select “CPU” under “device” for your render settings
[/quote]. Sorry if I haven’t been clear!

image

Seems that it doesn’t work either. I think I really need to wait for my new computer to arrive. It will never be fast enough!

The new computer fixed all my problems! Thanks everyone for your help!