Objects rotate (unintendedly) when game starts.

Hello.

I’m new on the forums and relatively new to the Game Engine.

I ran into this problem that I have no idea how it came to be or how to fix it. Giving you an image to get a picture of things:

http://s18.postimg.org/8xny74le1/problem01.jpg

On the upper picture (1.) is a screenshot from the standard 3d-editing view where I’ve set three rusted roofing plates to rest against wall. Object-wise they’re nothing special, just a standard plane, cut a few times to make the wave pattern out of the faces and then added UV-texture on them. Then moved and rotated them against the wall, to make them look like they are resting against it.

On the lower picture (2.) the game engine is running, but the roofing materials have fallen on the floor and partially through it, at perfectly flat 90 degree angle. This is not intentional and I have no physic properties set to the objects, not anything at all that would make them fall on the floor by gravity (as said, they’re basic added plane, which has just been stretched and UV-mapped).

Additional info:

  • When the playable character moves over the roofing material when they rest on ground, they jitter and roll around uncontrollably, but don’t move, just roll around.
  • As a test, I added a cube next to the roofing materials and rolled it around in different positions and ran the game engine, but it wasn’t affected by the same phenomenom. But when I repeated the add plane -> modify faces -> add UV-map, the problem re-ocurred.

Can anyone help with this? It would be my intention to have these objects just rest against the wall like they are in picture number 1, they’re merely decoration in the game and are not meant to be interractable or active in any way.

Thanks in beforehand!

Check the bounds of the objects. They should probably be ‘box’ type. If they’re rolling, they are probably currently spheres.
Turn on physics visualization and see if you can spot the problem.

Also some textures aren’t mapped properly (check your material settings) and some normals (the walls) are flipped. Try using ctrl+n