Objects that exist in the scene but won't render

I am struggling to understand why an object in my scene (a glass) will not render, it has ray transparency enabled, however the mug,saucer and spoon all have ray mirror enabled

why does the glass not show up? :confused:

http://sites.google.com/site/toby3d/forumscene.jpg
Here is a picture of the scene

http://sites.google.com/site/toby3d/coffeemug3.jpg
And here is a render.

Sorry for the large size, for some reason I cannot save rendered images as anything but a targa file now, which is also confusing?

If anyone can shed any light on this it would be much appreciated.

Hi,

This may be a silly question, but you don’t have alpha set to zero, do you? Is the glass on the same layer as the rest of the objects?

Also check the traceable button for the glass material.

Hi,

And check the Oops schematic to make sure it’s renderable.

Make sure your cup is not on a render layer that is disabled.

You could always post the BLEND.

Thanks for the ideas, unfortunately none of them are the cause (at least I don’t think so, I might have looked in the wrong place)

Here is the .blend file,

any ideas???

Attachments

coffee mug.blend (249 KB)

The object does not render because you have a particle system on it with ‘Emitter’ disabled…

Oh… that’s strange.

How do I remove the particle system??

see lower post

These seem to be particles from the fluid system.
F7 --> Physics Buttons --> Fluid Section --> Uncheck ‘Fluid’

EDIT:
Just noticed the particle system is more insistent than I thought. Deleting the fluid system will not delete that particular particle system and there is also no “x” button in the modifier overview.
Here’s what works: Uncheck ‘Fluid’ as stated above. Delete the subsurf modifier with it’s “x” button. ALT-C the glass to mesh (Delete original). Reactivate the subsurf modifier.

Strange thing, though…

@Ikari
I have unchecked the fluid button but it still won’t appear in my render?

@Spacetug
I’m not sure where the X is mate am I looking at the right place?
http://sites.google.com/site/toby3d/screen.jpg

Please check the EDIT of my above post…:wink:

EDIT:
Just noticed the particle system is more insistent than I thought. Deleting the fluid system will not delete that particular particle system and there is also no “x” button in the modifier overview.
Here’s what works: Uncheck ‘Fluid’ as stated above. Delete the subsurf modifier with it’s “x” button. ALT-C the glass to mesh (Delete original). Reactivate the subsurf modifier.

Strange thing, though…

Thanks Ikari,

Just out of interest what does alt-c do??

is it a copy of the original? If it is what is the difference between that and a duplicate?

Thanks again :slight_smile:

Quite frankly, I had no idea how to get rid of this particle system. So I just tried ALT-C, which to my knowledge (in this context) converts all modifiers at once to mesh - just like clicking the ‘apply’ button for every modifier.

Therefore I asked you to deactivate the subsurf modifier before ALT-C: Otherwise subsurf would have been applied to your glass mesh permanently, too.

tried with the .blend,
change fluidsim type to domain, then disable fluidsim.
that gets rid of the pesky fluid particles

edit: the glass material needs work–try adding some ray mirror, changing specular shader to ward-iso, and making sure that reflection+spec=1

Thanks for the advice Spacetug,

the glass material needs work–try adding some ray mirror, changing specular shader to ward-iso, and making sure that reflection+spec=1

But what do you mean by reflection + spec = 1 ?? I have the specularity set to 0.75 on the ward-iso shader which setting should I change to 0.25 :confused:

Here is a render with the glass in it,

It seems too translucent at the base I think.

http://sites.google.com/site/toby3d/glass800x600.jpg