Objects with paint- coming out weird in render

Hi all,

I hope everyone is doing well. I am a fairly new user to Blender and I have been having an issue with paint. I use the Material Properties tab and select the color I would like to use, however when I am ready to render my scene it comes weird and it is not smooth paint (sorry I do not really know the term for this issue). Textures come out completely fine; I have no issues whatsoever. When viewing the image, please look at the ceiling, the gray cabinets, as well as the left wall. If anyone has any suggestions or can help me fix this issue I would greatly appreciate it. Maybe my render and/or camera set-up is not correct?

Thank you very much in advance.

My guess is that you need to render with many more samples… likely double, to start…

1 Like

Thank you so much, increasing rendering samples did seem to make it much cleaner. Longer render time but I don’t mind.

You are new, so we will let it slide, but please note that it is customary to give a :heart: and hit the Solution checkbox when someone solves something for you Aakash.

Don’t forget denoising can be a way out of noise. It also appears that many areas are lit only by bounced lights. That will always induce tendency for noise. Adding lights to add direct lighting can help camouflage the noise from this.
Completely unrelated, but are you sure you want backsplash to go all the way to the ceiling? Usually they would be cut flush with bottom of top cabinets and have regular wall above it.

Thanks for the response. This is not completed yet, I am actually still messing around with everything, but I wanted to address the issue I was having and seeing what I am doing wrong. The higher the sample rate did infact fix the issue. And yes, I did click the de-noise option! Thanks again. Cheers.

Try activate denoise data but turn off denoiser. Then in post use the denoise node using Image, Denoise Normal, and Denoise Albedo. Here is a tutorial on what I mean:

1 Like

Thank you for this. I will check it out.