Objects won't show up in game engine?

I made a tree with bezier curves, then converted it to a mesh so that it would show up in the game engine, and it did, until I used the scripts window’s “fill twigs” and “generate leaves” options, and now they don’t show up in the game engine even if I convert them to meshes again.

Go into Textured mode (Alt+Z) Your normals are probably messed up. Go into Edit Mode>Select All (a)>Ctrl+N to recalculate normals.

still didn’t work :frowning:

I got the tree and the branches to show up, but not the leaves. I used the add leaves button, which makes little gray squares and then the leaves that you selected to go to the branches, but in the game engine only the little gray squares show

Ohhhh. That is probably because you don’t have GLSL selected in the Game Menu.

I checked, and I have blender glsl materials selected, and all options under glsl material settings selected :stuck_out_tongue: :spin:

I added a hair texture to the ground to make grass and that wont show up either!!!

Particles and hair don’t work in the Game Engine. Use a texture. You should look at the Yo Frankie files to see how they did they’re grass.