Objets not touching each other? (floating shadow)

Hi there…

I’m sure this question has been answed 10021252369 times before…

I’m sorry, but I did search before posting this. The result was over 600 threads…

This is driving me crazy: My shadows make objects look like they don’t touch each other, even when they do…

It looks like this:
http://img380.imageshack.us/img380/2265/shad8wx.th.jpg

I have changed every parameter I know about! :-?

Is there a way to do it without ray shadows? Or at least make it look better?

Thanks!

What kind of Lamp?

%<

Hey! You? Here?! :smiley:

It’s a spot…

Use an area lamp. With a Spot set to BuffShadows you can adjust the ClipStart and ClipEnd so they’re as close to the scene as possible (but not in RayShad) which eliminates that problem. Area lights give better shadows anyway (unless you want special effects).

%<

I can’t afford raytracing… 800 Mhz here! :smiley:

And i have to render a basic, but quite long animation…

I’ve tried adjusting ClipSta and ClipEnd, and it does look much better… It’s good enough for what I have to do!

I had no idea those two were responsible for that…

Thank you again! :wink:

The bias value is set to high by default for most scenes. In the following images all settings are the same except for the bias value.

bias = 1
http://members.shaw.ca/rjplus/bias.jpg

bias = 0.1
http://members.shaw.ca/rjplus/bias1.jpg

GreyBeard

Yep, it’s even better with a low bias!

Thank you!

Oh by the way GreyBeard, are you planing on releasing some new great, delicious, excellent, wonderful, useful, fantastic video tutorials? :smiley:

Would it be possible for an optimize button be incorporated into the lamps? I mean, to automatically set the Clip Start and end points for objects in it’s range?