Occluded geometry visible, what did I press?

I’ve pressed or clicked soemthing. You can see that the edges behind are showing partially through. It’s not the visibility buffer mode, it’s something else. What have I pressed, it’s driving me nuts.

Did you by any chance mess around with the view clipping values? I seem to recall that setting the “Start” clipping value too low can cause artefacts like this:

Yup. I had my clipping at 20 thousand. Changed it back to a few hundred. Thanks.