Ocean blanks out my textures

hi, this is a tutorial i did to make an ocean, so far so good. But when press p, wherever there is a texture plane, like fire or clouds, the ocean cuts out the texture, it is only present on my skydome. (like off in the distance, ocean is blank but the part of texture above horizon is fine so its got to be the ocean, if you know what i mean)

it seems to occur only with textures where z transparency is ticked in the properties panel

also, how can i set the ocean so its partially transparent so the bottom of the cube can be “merkily” seen.

blend file:


edit, when i say i did the tutorial, i mean i followed along-not made the tut. just clarify

Hard to debug since you didn’t pack the textures, the scene is just blank black :stuck_out_tongue:

Can you link the tutorial that you used?

Aha! makes sense. I moved the file to my desktop to check and the packing is working, unless blender can somehow search around to the original destination folder, but i dont think it does.

here is packed blend:

also this was the tutorial on how to make the water

It’s an issue about Z transparency order, something I’m not an expert on unfortunately. But basically when you use two transparent polygons that overlap you can get errors in order. There are some options in “alpha blend” but don’t have time to further test it, sorry :confused: But you should perhaps make those rocks 3D or at least 2D with clipping the shape in polygons to get rid of the need for transparency.

You can make the water transparent by adjusting transparency in the “Transparency” part. You have it set to 0.0 but you are having the texture file affect the transparency (tick in texture influence with value 1) and since the texture doesn’t have alpha map 1.0 is added for every pixel. Disable texture influence to transparency and you get the water transparent. After that setting the material transparency for 0.2 etc does the trick.

EDIT: Couldn’t leave it at that :smiley: Looks like setting both water and rock texture to “alpha clip” fixes the draw order bug.

cool. my main issue however is the transparency thing as i have explosions and other stuff clouds and they all disappear when i add my ocean depending on what angle you’re flying. where could i edit the order of z transparency

wow freaky. you dont know how many different things i tried, change play fgame, check, return value change something else. now first go, i checked mask instead of z transparency. magically, texture is all present. voodoo.

thanks for your input :slight_smile:

Just make sure you use “alpha clip” for objects that don’t need fading outlines like the rock and “alpha sort” also seems to work if you need fading outlines such as for clouds.

But with “alpha sort” you can’t have one part of the face above and one part below another transparent face, one face seems to always be drawn completely on top of the other.

thanks alot, that actually worked better than mask.