Ocean scenes - Realistic

(cuzner) #1

Hi all,
I have been trying to create a realistic beach scene after a smack of inspiration from COGS ocean tutorials on his site (the man did good!)

I have not yet found any work in blender that accurately creates a beach scene with realistic water.

The effect I am trying to create is the transparent quality of the thin film of water and foam as it flows up and down the sand.

My model is using all UV MAPS for the contact point between the ocean and the beach.
I have tried using alpha channels in all the settings I can think of but I have had little success.
What I noticed was that when I use raytrace the alpha is always black.
When I use Z-transp instead of raytrace it will create the alpha as I intended.

Using Z-transp is no good as the water is not realistic.

I have been tearing my hair out over this for weeks, has any one got any useful advice, is it even possible currently.

Blender rules!

0 Likes

(cuzner) #2

This is a section of the scene I have achieved so far, but notice the lack of transparency in the foam.
Not what I am after!

:frowning:

Attachments


0 Likes

(olivS) #3

Did you activate the TraShadow button in the shaders panel of Material buttons? What you need is transparent shadows, and the material receiving the transparent shadows should have TraShadow ‘on’…

More trivia on transparent materials:

http://feeblemind.tuxfamily.org/dotclear/index.php/2004/12/26/7-didacticiel-la-refraction-tutorial-refraction

0 Likes

(cuzner) #4

Ha, I forgot all about trashad, although it had no effect, I ran it through Yafray as well and it was totally screwy!

Thanks for the advice tho.

0 Likes

(cuzner) #5

If I turn off colour map in materials the alpha kicks in but then obviously I lose the colour info from the uv map. The black is in the colour mapped alpha areas in both .TGA and .TIFF files

0 Likes

(olivS) #6

yafray doesn’t support ransparent shadow. Blender internal only: it has to have an effect on the render, or you applied the Trashad to the wrong shader… :-/

0 Likes