OctaneRender™ Blender 2.8 plugin free version 2019.1.4 released

The free version is fully functional except that it’s limited to one GPU.

Free and Sub versions are based off of 2019.1.2 so no RTX support. That is coming with 2019.2 version. Free version is limited to one GPU, yes. While the sub to two GPU’s. There are mentions of plans to have an intermediate subscription model but no news so far.

What does this “Free Tier” actually mean?
EDIT > okay i read is limitied to 1 GPU. Why not make that clear?!?!

I also noticed that on the install page it states this renderer doesnt need an addon. Yet it is an addon??? Why is that?

Also it states that on OSX we can have multiple instances running. But i can run 4 blenders or more at once, no issue?

Hello,
Hope someone can help me with this “problem” - My preview is totally overblown and colors are totally off. ( same for render )
Material color for the body should be a dark pinkish one and the top should be black.

  • Render settings: display device: sRGB - also setting it to “none” made it even worst.
  • Octane Camera Image under camera settings is turned on and set to “sRGB” - “linear/off” doesn’t make a lot of a difference.

Tasting with a different HDR makes no difference also.

Changing the gamma to 1.0 makes the whole image dull and grayish.

Probably this a beginner mistake if this has to do anything with right gamma settings ( dont know much about linear workflow ) - but Iam a bit overwhelmed where I have to set it right. I can change it in the render settings, the camera settings and in the hdr image node.

Can some help me with that? Thanks in advance. I am using the octane free version haven’t tested it with the paid version yet.

Hi @VONNOWAK

maybe, i can help you. try this option:
Octane Camera Settings, go with linear/off and set Gamma to 2.2.

grafik

this should be fix your other problems

1 Like

thank you @dobe for your reply. Unfortunately, your advice doesn’t help. The image is still unchanged and totally blown out. The only thing that helps is to set the gamma in the hdr node to “1.0”

Here is the difference between those two settings:

  1. gamma in hdr node untouched - camera settings gamma 2.2
  2. hdr node set to 1.0

try setting both to sRGB end choose Raw for visual transform
and lower your HDR to around Gamma 1 (more or less)
also check if both Octane Imagers have the same setting (to ensure that render and preview looks the same)

octane

I have updated the first post for the latest release 2019.1.4 of the Octane plugin for Blender. It now includes downloads for Linux and OSX. :smiley: No RTX support yet, that will be when they release 2019.2.

Jason

1 Like

Ok, this is an awesome version to come out, they have finally put in a material converter that will convert Cycles “Principled BSDF” into Octane’s “Universal Material”. It’s a one click deal, very cool, and you can find it under the Material properties tab. Here is the change log:

NEW FEATURES SINCE LAST RELEASE

Upgrade to 2019.1.4
Support Octane VDB animation(same as 18.x)
Add converters for converting Cycles Principled BSDF to Octane Universal Material
The converter can be found under “Material-Converters-Convert To Octane Materials”
Now only “Cycles Principled BSDF to Octane Universal Material” is supported. More types can be added in the coming versions.
Add OSL Delayed UV Projection
Add Vertex Displacement Mixer
Reorganize kernel as SA layout
Support to disconnect visible environment
Support to resolve the target node without outputs for octane DB material

FIXES SINCE LAST RELEASE

Removed deprecated environment settings structure
Hide Eevee/cycles nodes in octane; hide octane nodes in other engines
Fix subdivision mesh issue
Fix color vertex data error
Fix Z-Depth pass crash
Fix the export issue for single frame scene
Fix the ortho camera wrong positions issue
Fix ortho camera render issue with portrait mode under final render
Fix the auto-refresh issue for animated image
Fix probabilistic render freezing on OSX
Fix the int value scope issue
Fix Eevee HDRI render issue
Fix the ramp setting issue for gradient texture and volume ramp texture
Fix some connection issues in the octane node graph
Fix render the issue of AO texture in the kernel
Rename “Toon Direction” to “Toon Directional”
Rename “Matte” to “Shadow catcher” in Diffuse Material
Change bump socket from float to shader type
Remove Octane prefix

KNOWN ISSUES

Materials with dynamic layer configuration(e.g. Group Layers, Composite Materials) are not supported in LiveDB and LocalDB
Global mesh type override is not included in the current release

2 Likes

Can Octane create sharp caustics as LuxCoreRender does?

Like all pathtracers, Octane has issues finding those paths that cause caustics. You can use MLT or Bi-directional pathtracing, but it’s impossible to transfer those algorithms to the GPU, at least right now. You can try the PMC kernel in Octane, which is a sudo MLT, but it has it’s issues, and hasn’t been updated for some time. The denoiser also helps a lot but the less samples per pixel you do, you will not get as much detail in the caustics. I have also used the render region to focus the renderer on just the caustics. Works for static images, not so well for animation.

I guess it depends on what you want? Here is a simple test scene I did to play around with caustics in Octane. I don’t remember how many samples per pixel, maybe 6000 to 8000.

Convert materials doesnt really work, it just changes the cycles principles bsdf to a default octane universal material, it doesnt take in to account the textures or settings applied to the principled shader.

What about using a renderer which works now, is 100% compatible, stable, faster and will contribute back to Blender? :slight_smile:

3 Likes

I’m guessing that your Cycles material was more complicated than the ones I tested.

Here is the Cycles render with it’s materials:

Here is the material after converting to an Octane material:

Here are the breads in Octane after I adjusted the exposure of the render:

Great job on the models and materials. You some kind of baker with the licence to Blend? :smiley:
Looks like Octane is doing something to the HDR, with shadows becoming very sharp.

Check the PMC kernel

The PMC Kernel is a custom mutating unbiased kernel designed specifically for GPU rendering. Rendering with PMC creates physically accurate lighting and caustic effects and is generally produces the highest quality result but can also take the most time to render depending on the scene…

Huh that’s weird, I just have a simple texture into the base diffuse, and when I click convert it just changes it into a default octane material and discards the image textures and any other setting (roughness, specular)
Just basically resets everything. Very odd.

Unfortunately I’m not the baker. :slight_smile: Octane is not using the HDRI but instead is using It’s daylight environment with a sun.

Ah, the converter only works with the “Pricipled BSDF” node right now. Are you using that node for your material?

Yep that’s what I always use. Weird :confused: