OctaneRender™ Blender 2.90.1 plugin version 2020.1.5 - 22.0 [STABLE] released

I personally in Octane Blender have only couple addons enabled ( node wrangler for example ). All work is done in “regular” Blender so I just open Octane Blender , load scene and continue work. I do not understand this “reason”.
Separate Blender distribution is not big hassle. Bunch of people already use different software, Zbrush, Moi 3D / Fusion 360, Substance Painter-Designer, 3D Coat, etc. Switching between Blender distribution is like restart Blender. Much more easy than switch between different software, right? Nothing more, nothing less. How many times you have Blender crash or restart Blender because… reasons?
True Cycles is better integrated, also there is much more resources for Cycles, from tutorials to materials or complete projects. Lack of material preview is PITA, especially when you only need to adjust scale of texture. Anyway everyone must at least try. Truth is real master can achieve same result in any software, like one dude say: I can make it and render in toaster :grin: Sound funny, arrogant… but he probably can do it, judging by his work.
Again, instruction for Octane Blender installation.


great channel, check his other videos.
Also do not hesitate to watch Octane tutorials for other software, like

there are difference, but principle are same.
3 Likes

My main issue with the separate Blenders is the version difference. I’m used to working with the latest features and fixed bugs in the Blender daily alpha builds. After making a scene in 2.92 alpha, there’s a chance of crashes and missing features that I used in my scene when I open the same scene in Octane Blender version 2.9.

I just submitted this LuxcoreRender bug report. The example scene was made in 2.91 alpha, and keeps crashing in 2.83 and even 2.9, so I had to ask the developer to install 2.91 alpha (beta by now) to be able to open the scene.

But if you’re used to waiting for an official Blender release before updating, then the delay between the Blender release and the Octane release isn’t that big.

1 Like

Ugh… you probably have right. This is curse of Blender “Worp Speed” development :grin:
Constant changes are nightmare for developers, I guess. Do you try to collapse modifiers… to make scene more… “unified” almost like you want to export. I remember problems of Autodesk users. For example, 3D max have great modifier stack, but sometime user is unable to open old scene with complex modifier stack, solutions is to collapse stack in old Max and save. Maya have his “famous” history… which is so good that many users have button to clear history :wink:

This is price when you want to Live On Edge.

1 Like

Ah yes, 3ds Max was (is?) a nightmare when it came to backward compatibility. :sweat_smile: I moved from Max to Blender in 2012. Before that I worked with Max for many years. The worst period of the year was the period when a new Max release had broken the plug-in compatibility again, causing the need to wait until all plug-in devs had caught up on that.

Sorry for going off-topic, guys. :blush:

1 Like

Well, it’s good to remember such things. Luckily Blender addons do not broke to easy :slightly_smiling_face:
Although I think that when you want to save Blender scene for future usage, make one "clean"copy with modifiers applied, except bevel and subdivision which can be deleted and applied again. Same with addons… who know how Blender will look for 3-4+ years. So instead to search for older version, you can have one file which can be opened in future.
I have some old C4D project with :“some plugin missing in this scene” message. Then I scratch my head and try to remember what I use… but if this is project from someone else I’m often helpless.

1 Like

When I’m working on a texture I usually go to the “Shading” tab. With Octane set as the renderer, I can make changes to the texture and see it update in the viewport. If you have a lot of objects you can do Shift-h to hide everything except the object you have selected.

There is an issue I run into every now and then, is that if the current shader nodes that you are working on are invalid, Octane will stop updating the viewport. Once I have the node tree correct, I will just adjust the viewport view a little (rotate it) and Octane will start again.

I have no problem seeing the changes happening when I’m transforming textures, etc.

1 Like

Hey! I was wondering if anyone here has upgraded to a 3000 series graphics card? I just received my 3070 and having such a pain getting octane to work. Hell, even cycles had issues. Only the 2.91 version seems to work, and that’s just for Cycles. Is it a case of waiting for the next Octane build?

As a result, everything works, except for denoise and upsampling.

Can you please tell me if it is really impossible to preview the material on an octane ball like in other renderers? Or will it be possible in the future?

1 Like

In the Blender Render Settings of Octane there’s a section with buttons including “Show Octane Node Graph” and “Show Octane Viewport”:

Maybe “Show Octane Viewport” includes a material preview setting? Someone else here might know more about this.

You have Octane working?

I am not looking for a replacement for Corona and blender crutches). I need the tool Octane has become in the blender lately. But thank you for your answer.

Well, yes. Except for denoise (
At first it didn’t start until I downloaded the new build, but it was almost a month ago. I think you have already downloaded the new build.
Can you try “show octane log” like in screen below? It helped me to understand what the problem was.

with the 3070?

I’m now getting this message:

Last Octane engine log entries:
CUDA error 2 on device 0: out of memory
-> failed to allocate device memory
device 0: disabling RTX acceleration as mesh data cannot be placed into VRAM
CUDA error 2 on device 0: out of memory
-> failed to allocate device memory

Sorry, full message:

Octane: ERROR. Server log:

Failed devices:
GeForce RTX 3070(device 0), error message: “CUDA error 2 on device 0: out of memory -> failed to allocate device memory”

Last Octane engine log entries:
CUDA error 2 on device 0: out of memory
-> failed to allocate device memory
device 0: disabling RTX acceleration as mesh data cannot be placed into VRAM
CUDA error 2 on device 0: out of memory
-> failed to allocate device memory

I can assume that it lacks just enough memory, and to get out of core you need to disable RTX.
Not since 3070. Of course, my assumption is correct only if it is a large scene). If you try to run just a renderer with a cube and you get such an error, I’m not a master in this and all I do is experience. So maybe you should contact technical support. I was quickly answered to my questions there.

Ahhh that fixed it! I thought I’d gone through every option, but entirely forgotten to diable RTX in the device preferences (rather than blender preferences).

So thank you for that!

Re: scene file - the current file opens fine on my other computer (rtx 2070 super), which has the same VRAM as the 3070, yet doesn’t open with the 3070. Do you have any ideas why that might be?

Someone at the Octane Discord server mentioned that there should be a shaderball somewhere in Octane for Blender. I’ve searched everywhere, but can’t find it. Does anyone happen to know the secret Octane shaderball hideout in Blender? It would be a nice way to avoid having to activate the full viewport renderer.

and just like that, it stopped working again!

ANother thing I noticed, if I dive into the settings on my 2070 computer, it says total available device memory 8192mb, and that the cores = 2304. When I dive into the settings of my 3070 comp, it says 0 available memory and ‘?’ next to cuda cores.

:thinking:… here’s one

MY Octane Shader Ball by lv3628800 on Sketchfab

2 Likes