OctaneRender™ Blender 2.92 plugin version 2020.2 - 23.4 [STABLE] released

Im using 23.4 build of octane blender and it seems ok for me. Maybe upgrade?

it was a bug and should be fixed in the new version.

Upgraded to 23.4 and that seems to have done the trick.
Thanks for the reply’s everyone :slight_smile:

I have a quick question. In 2020.2.4 Smoke simulations are appearing as a white block still even with a volume medium. I have baked the smoke simulation as modular. I have looked around for some way to notify octane of the cache or something but the only information my research has found refers back to earlier verisons where you needed to go to the object data and enable VDBs but I have learned this method has since been removed. What is the current method of rendering a smoke simulation?

OctaneRender™ for Blender plugin. Windows, Linux and OSX versions. The download links, provided on this page, are for Enterprise License Holders.

Important Note: This version has reverted to version OctaneRender 2020.2, due to issues identified with the 2020.2.1 integration. This version still uses Blender 2.92, and we will be seeking to reintegrate OctaneRender 2020.2.1 in the very near future.

OctaneRender Studio subscribers can access their software from the “Downloads” section of their Customer Account Page.

NEW FEATURES SINCE LAST RELEASE

  • Reverted SDK to 2020.2
  • Supported the Octane AOV feature

FIXES SINCE LAST RELEASE

  • Fixed the crash when using the Object Data node with an Empty
  • Fixed the crash when opening “Octane DB” during the final rendering
  • Fixed the opposite rotation issue
  • Fixed the extra “recreate mesh data” for the hidden objects when exiting isolation mode

How to use the AOV feature in the OctaneBlender

unnamed.png

You can also find an AOV sample here:

AOV_Sample.blend

(2.12 MiB) Downloaded 6 times

This latest version crashes OctaneServer for me on Linux Mint 20 when I try to render. Even with just the default cube. Does anyone else have the same issue? I’m running version 460.56 of the Nvidia driver, with a GTX980 just used for the displays and a RTX 2070 for rendering on.

Jason

Same here on PopOS 20.10

Thanks, it’s good to know that it’s not just a problem with my system. :slight_smile: If you wish, you can add a post to this thread here for this error.

1 Like

This is the maintenance release 2020.2.2. It fixes various issues that got reported since 2020.2.1 including a couple of annoying problems.

You can find an overview of the changes between 2020.1.5 and 2020.2 in the release notes of 2020.2.

Make sure to use a NVIDIA Studio driver with version at least 456.38 on Windows or 455.23 on Linux to use this version. No driver updates are required for macOS 10.13 (CUDA).

This version supports the NVIDIA Ampere architecture (compute model 8.x) on Windows and Linux. As a consequence, Kepler GPUs with a compute model lower than 3.5 are only supported on macOS (which doesn’t have Ampere support) and needed to be discontinued on Windows and Linux.

Changes since OctaneRender 2020.2.1:

Improvements:

  • Improved performance in some scenes with a scattering environment medium when using RTX.

Bugfixes:

  • Fixed crash in the surface scatter node when you try to use the area based distribution on a mesh that doesn’t have polygons.
  • Fixed portal material being non-transparent to shadow rays.
  • Fixed clamping of HDR input values in the color correction texture.
  • Fixed CUDA failure when rendering toon materials.
  • Fixed incorrect rendering of toon materials with opacity < 1.
  • Fixed CUDA failure when vertices of a mesh are moved around in quick succession and RTX is enabled.
  • Fixed broken auto bump of vertex displacement if dirt is used in the material as well.
  • Standalone: Fixed missing update of the displayed gradient of gradient texture nodes in the node inspector.
2 Likes

This is a quick bugfix release 2020.2.3 to sort out some easy to fix but annoying problems found in 2020.2.2. Apologies for the hassle of having to update again.

You can find an overview of the changes between 2020.1.5 and 2020.2 in the release notes of 2020.2.

Make sure to use a NVIDIA Studio driver with version at least 456.38 on Windows or 455.23 on Linux to use this version. No driver updates are required for macOS 10.13 (CUDA).

This version supports the NVIDIA Ampere architecture (compute model 8.x) on Windows and Linux. As a consequence, Kepler GPUs with a compute model lower than 3.5 are only supported on macOS (which doesn’t have Ampere support) and needed to be discontinued on Windows and Linux.

Changes since OctaneRender 2020.2.2:

Bugfixes:

  • Fixed missing render update if a toon ramp is modified.
  • Fixed superfluous geometry updates when an input of a volume node got changed.
  • Fixed specular transmission “leaking” into the indirect reflection render pass.
  • Fixed crash when you authenticate more than once in a session.
  • Standalone: Fixed crash when rendering a geometric primitive that just had at least one of its inputs collapsed into its pin.
2 Likes

My license is activated by using my OTOY account but It will not render. All I see is “Waiting for Image…”

Hi,

There are a couple of things that can cause the “Waiting for Image” issue. The most common one in my experience has been that the texture node graph is wrong. Look for red links between the nodes, although sometimes there will be none and it’s that you have connected incompatible nodes together, etc. Another reason is that you have a server/plugin version miss-match.

When I have problems like this, I will run both OctaneServer and Blender in command line terminals, so I can see any error messages that they are generating. If you see some errors, post them here, and we will see if we can figure the them out.

Jason

octane settings buttons (show octane log, device preferences) don’t work too :slight_smile:

anyways, I will not waste my time

Ah, I see, what are your GPUs? Your issue is that Octane can’t find any GPUs to render on. Unless you are running OctaneX, you need to have some Nvidia GPUs that are not too old. I think the GTX 700 series or later work, but I would need to check. If you have Nvidia GPUs and are still having issues, than I would look at the drivers. You might need to update the drivers or get them to install correctly.

I don’t think that the Blender plugin supports OctaneX yet, so you would be limited to standalone for rendering.

Hi

I have a Nvidia GPU. Previous octane version worked fine on my machine.

do you have a camera in your scene?

I deleted default scene properties (camera, light) and create a new camera (octane camera box checked) Same result again. I tried all possibilities and nothing solved my problem.

try the octane for blender facebook group, one of the octane support guys is answering quite frequently there.