Odd Artifacts in Eevee

Good day,

I’m going to start texturing and lighting this house. It’s the first thing I’ve ever seriously textured and I think I’m ready for it. I’m going to do the whole thing with Eevee as my target renderer.

While I probably wouldn’t be working with Render Preview mode except to check things as I go along, the first thing I noticed that, even without any materials started, I’m getting a lot of odd visual artifacts. I turned off the floor grid display and the artifacts aren’t just on the ground, so it’s not that. I have the shadows and volumetrics and reflections where I want them, but I can turn them on/off or adjust them if I need to.

Am I missing something basic? See attached screen capture - more are available if you want to see them. I’ll throw the .blend on Google Drive too. The house isn’t mine but it’s a freebie from Blender Market - I’m taking the author’s source mesh which he/she had already textured and I’m redoing it myself for the practice.

Thanks! :slight_smile:

  • Mark

Hi.
What is the story of the scene? Have you started it in 2.79 or in old 2.8?

If I copy all the elements of the scene to a new instance of blender in empty scene, the problem does not seem to occur. Even if I append the whole scene to a new instance of blender it seems to be working correctly.

Hmm. That’s odd. I’m using 2.8 exclusively. I don’t like 2.79 and I didn’t use it for very long before switching to 2.8. There must be a problem with the way that I’m setting up my startup.blend file.

I’ll bet that if I loaded the standard-stock Blender startup.blend and copied over the house and the ground box, it would eliminate the problem. However, I like the way that my startup.blend is working except for this particular problem.

If it’s not too much trouble, can you see any serious problems with my startup file? As I mentioned, it’s all 2.8. I’m not asking you to fix it or anything - just pointing me to an area I can research would be wonderful.

Thank you again,

Things to check when such artifacts happen:

1- Apply scale to your objects
2- Use a reasonable values for clipping start and end for both viewport and cameras.
3- Check contact shadow settings of the light, disable or tweak them to see if it’s the creating the problem.
4- Try using VSM shadow method with high bit depth.

The point is that if you created your startup.blend in 2.8, I think the problem should not be happening.

I think that just in case you could report the problem and sharing the scene and your startup.blend with developers. Developers will determine if it is a configuration problem or something corrupt

OK…I looked and that kind of problem tends to happen when you have 2 LODS occupying the same place…I checked and removed doubles and only dropped a few vertex…If I load up yours with your UI the problem is there … and if I look at it there is a ground plane as well as the same plane attached to the house mesh… perhaps if I changed the setting in remove doubles it would see it…as they may occupy the exact same place ?? I don’t know…If you separate the house mesh…you end up with the House Mesh and all the parts that make it, again that should not happen…?? Now there is the camera…if you delete the camera and replace it a align the camera to the screen view…The problem goes away…??? I checked the camera and I see that it has animation, but replacing fixes the aberrations. I have no idea why …but delete and replace the camera. Just doing that gets rid of the artifacts. Or you could just open blender with your default and append the House.blend, and select House - Medieval 01.blend\Object\ … and select all the files in there…that will also fix it and keep your UI…!
Appended from your blend…

and just changing out the camera…


Good Luck!

Your reply got me thinking about why the viewport had a problem while in Perspective View, but not Camera 01 View.

I usually set my Perspective Viewport clipping to ridiculously high and low levels so that I can zoom waaay in on a mesh while I’m editing. As it turns out, all I had to do was adjust the clipping. Everything looks perfect now, thank you everyone!

Well I saw that …and adjusted down to around 1000 and still had the problem…so it must be something combined with clipping and camera/UI that causes it…But I am glad it works for you!

So if this is not going to be reported, I mention to @hypersomniac just in case it’s not just a configuration problem.