Odd dark spots/shadows while rendering

Hi,
I’ve recently started using Blender for a University project and I’ve run into a bit of a snafu. The model I’ve created (a robot head) looks perfectly fine in the editor but when I render it I get these weird dark spots in odd places that don’t look like natural shadows. It looks even worse when animated too. I’ve tried recalculating the normals and messing with a bunch of lighting rendering settings (turning shadows off does nothing) and I’m not sure what the problem is. Can anyone shed some light on the issue please?


And because the forum isn’t letting me embed the video properly:

www dot youtube dot com/watch?v=qUZ8OoNJ4RY

Make sure your face normals are all pointing outwards.
Select all your vertices in edit mode (A) and remove any doubles (W / remove doubles) then recalculate the face normals (Ctrl+N)

Richard

Thanks for the reply, but as I mentioned in my original post I’d already tried recalculating the normals (as well as removing doubles, though I neglected to mention that) to no effect.

Is there any way to check whether my normals are pointing outwards?

If you have any faces that are actually inside the mesh delete them. Do you have the same effect if you set your object to flat shaded mode instead of smooth shaded?
Does adding am 'Edge-Split’ modifier help ?

Attachments



I think I fixed the problem, there’s an option called “No V.Normal Flip” under the Mesh tab. Checking that seems to correct the rendering issue without changing the look of the model.