Odd normal behavior after merging doubles


I want to start by saying I am no artist, so I apologize for my silly mistakes. I created a model inside of MagicaVoxel and then exported it to blender. By default every face is seperated, so to save on draw calls I combined the vertices by removing doubles. It wasn’t until I got it inside of the engine that I noticed very odd behavior, and tracked it back to the normals. I have some pictures of the normals before and after below.


Before merging. Looks good in engine

After merging. Looks very dark on the edges.

Things I have tried. (Will update with solutions provided)

  1. Recalculating normals

Thank you for your time,
Papa Beans

Looks as expected, normals get averaged. What you could try is to select one edge with only one connected face, select similar edges based on amount of connected edges, mark those as sharp. Then merge, enable auto smooth in object data properties: normals with high angle, and add custom split normals data in object data properties: geometry data for export.