Odd problem rendering a mesh

I’m having a werid problem with rendering a mesh. The mesh looks fine in object and edit mode but when I render it half of the mesh is missing! It isn’t a clean half either, bits and pieces are rendered and others not.
I’m sure its some goofy mistake…but I’d appreciate any suggestions.

a blend file or a screenshot would probably be useful here.

complete shot in the dark, how about rem doubles then ctrl-N to recalc normals?

good point…heres the mesh and a render


That’s probably a pretty good shot. Looks like the normals on the head are pointing to the inside, so you’re looking at the side that doesn’t render. Recalc normals should fix it.

Actually I did try removing doubles and then pointing normals to the outside…what I posted was after I’d tried both of them.

thought that, but usually double sided is on by default, so bad normals usually manifest themselves as weird interpolation problems like those black bands. If the normals were fully backwards with double sided off, they’d render as pitch black I believe, not transparent.

it might still be a normals problem so let us know if that fixes it.
If not, turn off ambient occlusion and give it a flat grey material to check if its a material problem.

also, it wasn’t actually a shot in the dark as I think fully half or more of rendering problems have something to do with normals, and a good portion of the rest have to do with alpha and transparency weirdness.

sorry, you posted while I was still writing. okay, so not a normals problem, try a flat material and turning off amb-occ, to see if some of your settings might be causing it. barring that, posting a blend file would probably be the quickest way, as opposed to guess and check.

Here is the .blend file. Thanks for the assistance.


You have multiple materials assigned to the object. The material for the head has Env turned on (in the Material panel). This makes that material transparent.

THANKS! I knew it was something simple.