odd rendering

hi all
i am trying to make a motorcycle dashboard
when i am rendering the mesh
the result looks a bit odd

probably i am missing something
can you please help me with it

also … ill be glad to ear an opinion if i model this mesh correctly

thanks you


forum_test.blend (292 KB)

Do you have two copies of the mesh in exactly the same place?
Maybe they’re in the same object. In edit mode, press W>remove doubles.
Or maybe your normals are flipped. In edit mode, press CTRL-N to recalculate.

If what you’re referring to are the triangular shading areas, then I think I can diagnose the problem pretty easily. I suspect the problem is that the quad faces you’ve used aren’t planar (that is, they’re not flat). When these non-planar faces are sent to the renderer, they’re turned into triangles, resulting in the strange hard edges you’re seeing.

There are a couple ways to fix this, but I’ll just cover two here.

The first and easiest is to select the object and Set Smooth in the Links and Materials section of the Editing (F9) tab. This forces Blender to (as the name suggests) shade smoothly across edges. It’ll try to shade across all edges though, which you most likely don’t want. To correct that, either fiddle with the Auto Smooth settings in the Mesh section, or add an Edgesplit modifier.

The other way to fix this problem is to make your faces perfectly planar. To do that, go into Edit mode (tab) and select a group of faces you want to be flattened. Then hit Alt-Space and choose Normal from the pop-up – this sets your alternate transform orientation to Normal, which is based on the direction a face is pointing. Next, his S for scale and tap Z twice (scaling along the Z-axis of the faces’ collective normal direction), then hit 0 and enter. That might seem a little complicated, but the faces should all be completely flat with each other now.

Hope some of this helps. Cheers!

Edit: Wait! Skip all that stuff. I took a look at your blend file and the problem is that you’ve turned on Tangent shading for the material. The tangent shading doesn’t work all that well unless a mesh has been UV unwrapped. Turn it off and your mesh renders just fine.

Tangent shading was the problem
thank you :slight_smile:

i just want to know
did i model this mesh correctly ?
cause i am still learning how to model