Odd Rotation Problems

I’m having the weirdest problem with Blender right now. Basically I tried a test build of Blender 2.7 64-bit, the official 2.7 64-bit, Blender 2.68a 64-bit and 2.68 32-bit and each time I have a problem where its hard to select the rotation gizmo and when I do select it the rotations rotate with the wrong axis of the gizmo.

The green Y axis part rotates around the Z axis, the x-axis is rotating around the y-axis, and the z-xis rotate around the x-axis.

I’m usign WIndows 8 Pro 64-bit and I’m completely stumped as you why this would happen.

If I use hotkeys the rotations are correct though, so I feel like there must be somthing that’s causing the gizmo for it do be off. Any clues on how that could happen or how to fix it?

as a pure guess (since there is no screenshot )
have you set the transform axis to something other then the default global ?

Not sure if I’m right but pressing R to rotate always gives you global rotation. Using the Gizmo you can change the locality of the rotation by clicking ‘Global’ and changing it to local etc. Try them out in different modes and see if the results are the same. Also, changing the pivot point may affect this.

I haven’t changed the transform axis to something other than global, in fact I used the “Load Factory Settings” options just to be sure. And it’s a bit hard to show in an image. It’s simply that the rotations aren’t right using the gizmo. Even when switching between global, local rotatino around origin, pivot, 3d cursor or anything it just has the axis wrong. I think I actually found the problem but it’s not something I’ve ever seen before. It seems like the input for clicking doesn’t line up with the actual gizmo.

As a test I clicks randomly and then clicked in a line in a random direction and plotted points on the screenshot based on which rotation it was doing. Here is the result.

It almost seems like the gizmo is either rotated wrong or the input is offset from the actual viewport/gizmo.

What makes it even more odd is that the viewport rotation ring still works as normal in the right position.

I rarely use the gizmo’s but just tried them and all work as expected so I’ve no idea whats causing the problem

Yeah, it was working fine on my old computer as well with the same blender versions. I’m at a loss as what could be the cause of the strange behavior. I was hoping there would be some way to fix it though, since I seem to have the problem no matter what version of Blender I use.