ODD shading

how do i prevent this odd shading. i need the sides flat.
one box is a copy of the other.
thanks

Attachments


ODDSHADING.blend (172 KB)

normals seem ok

one way which is sort of a compromise here
cause this will increase the number of vertices and split edges

use a edge split modifer that will give a nice face but all splitted in parts

another way would be to try to use subsurf but you need to redo your mesh!

try it and let us know

hope it helps

Hey anon125!

I fixed your blend file hopefully to your satisfaction. I did it by setting the whole thing to solid and then selecting only certain parts of the mesh, and setting them to smooth.

I hope this helps :slight_smile:

Attachments

Robo3Dguy-ODDSHADING.blend (142 KB)

Thanks
very well done!

Traingles=bad… they mess up your shading

can we lose the stripe on the front?
i tried - withouT success!

i don’t understand all the orange dots - where are the verts!!!

triangles again!

Attachments


anon125: Glad I could help :smiley: As Brados33 said,

Traingles=bad
Very true. Also, Boolean = really really bad. Try to stay away from them as much as possible (I’m assuming that’s how you make the tunnel.)

EDIT oh nasty stripe. I’ll try to fix that.

Here we go.

Attachments

Robo3Dguy-ODDSHADING.blend (142 KB)

WOW - that looks great! THANKS
i tried removing that stripe and making the whole front as one - with those 2 tiny triangles - didn’t quite look right.
where are the yellow verts? is this another blender setting?
thanks again

Your model was a bit messy, so I decided to offer a slightly cleaner version of a similar object

Attachments

ODDSHADING.blend (144 KB)

here is a pic of wht can be done with subsurf mesh

with holes

you could rebuilt your model with subsurf and a nice looking mesh

hope it helps

thanks very nice looking

thanks - where do i find a tute?
i usually stay away from subsurfing anything

add a mesh and turn on subsurf
then you shaope as required

for sharp corner youmay need to add extra vertex close to the c orner to make it sharp

see pic this is not super nice mesh but done in 2 minutes only
you adjust the level of render and mesh in modifier to make more rounder

now the higher the level the higher the final number of verticies in your mesh when you apply it !

hope it helps

there is also a sticky in midelling for loops and nodes i think
where you can learn more

hope it helps

I’ll have to disagree with RickyBlender on this one. If you’re gonna use subsurf, something like this is definitely the way to go (or that’s how I would do it anyway)

Attachments

subsurf_example.blend (132 KB)

I have to make another one.
so… how did you make your one?
i don’t see how you got the edges from the curve to be straight - not angled!
i need two smaller curves ideally with flat tops and the roof is curved!
i got this far…
but the front cutout top left corner needs something tidier!
thanks

Attachments



5th - 2.blend (162 KB)

to put the vertices in a straight line, I just selected them and scaled to 0 along the proper axis

thanks - but i have no idea what you mean!
Usually when i get a cube say and use boolean to chomp out a half circle - blender puts in all the edges from the curve to the cube.
I notice that did NOT happen when i did it to your shape.

thanks all

I didn’t start from a cube.

When modelling something like this it’s best to let blender take care of the part that is hardest to model. Since you have to start somewhere anyway, I think you should start by making the “hole” in this case.

I started by creating a cylinder, then removing half of it. Then I just selected some vertices and extruded them upwards, and scaled to 0 along the z-axis to put them in a straight line. Thin I repeated the process for each side, but when doing this I also selected one of the vertices created by the first extrusion (when extruding to the left I chose the leftmost one and vice versa).

hope this helps.