Offset Edges

add-ons

(Alain) #181

You can add a Shortcut to it and then you have just one step and the behaving like in Blender 2.78 :slight_smile:


(bliblubli) #182

The thing is that it was added to “edit tools 2” in official addons in 2.79. If you use this version, the interactivity is indeed gone (at least for me too). As it’s also in 2.79a, you can make a bug report at http://developer.blender.org


(StroBlend) #183

Thanks trying to help me guys but I want something simple --> the same behavior that 2.78, one click on my pie menu (that call the command) and voilà I can resize the width on the fly with my mouse then validate with the left click… LIKE BEFORE! LIKE OTHER TOOLS!:smiley:

@Alain: nope I don’t have this setting



(StroBlend) #184

bliblubli thanks, finally someone that can hear me I hope there will be someone that can fix this inconvenient ?


(Swarnim) #185

Like it, Thanks for making it.


(Doug) #186

Just curious if it would be possible to allow typing in the “Width” value during the interactive movement so that it is more consistent with the built-in Inset tool (i)? This would speed up our workflow a good bit.


(StroBlend) #187

I’m also interested, I asked it some time ago on this thread but no one seems to take it seriously. It is powerful operator and I use it a lot but since the Blender 2.79 they change this little thing that broke interest in this operator.


#188

Hello StroBlend,
Try install mesh_offset_edges.py from Bon_Baba’s github repository (look at first post).
Version included in Edit Tools 2 is too old (version 0.2.6, while Bon_Baba’s is 0.3.9).

mesh_offset_edges.py from Edit Tools 2:

bl_info = {
    "name": "Offset Edges",
    "author": "Hidesato Ikeya",
    "version": (0, 2, 6),


(StroBlend) #189

Hi, Thanks for pointed me out, I tried with the latest version but I got an error


#190

Here, it works, with the 2 add-ons activated.
Try deactivate Edge Tools 2 add-on.


(StroBlend) #191

Ok now it’s working as expected, thanks a lot!
First try I overwrited the built-in file, that’s why it didn’t work, here I just copied the last update mesh_offset_edges.py direcly in the addon folder and activated it from the preferences and voilà!


#192

Copy directly to the folder it’s not the right way to install add-ons.
Use File>User Preferences>Add-ons>“Install Add-on from File” command to install add-ons.

https://docs.blender.org/manual/en/latest/preferences/addons.html#header