Offset Edges

I figured it out

another function that for some reason does not work as a “modal wrapper”

@helluvamesh Just tested now that 2.82 is official (already 2.83 on the way) and it still hard crashed Blender when using Offset Extrude, so the fact that it was not a stable version of blender is not the cause, the addon itself is the cause.

Did you use this version?

If so, post a blend file where it happens, because this works for me just fine in 2.82a.

1 Like

Hi! I was testing on another version, but I just downloaded your version and the same hard crash is happening, and it’s only when “Interactive” mode is on, and only on “Offset Extrude”. And not only that but if you have Interactive active, but choose “Offset” or “Offset Move” then on the popup menu you change to “Offset Extrude” it doesn’t crash (but it’s not interactive), which makes me believe that there’s some kind of problem in the code when it tries to evaluate the mouse position when you activate the extrude option with Interactive ON, in order to make the operation interactive.

Obs: about the BLEND file, it’s always the default scene with only the default cube. I simply select the cube, enter edit mode, select edge, click on the Vertex menu>Offset Extrude, then a hard crash to desktop.

But, since you said that yours is working fine, I’m gonna try to deactivate all my addons (I have a bunch installed) to emulate a fresh install, except for this one, to see if there’s some incompatibility going on (ps: I’m using 2.82 but not 2.82a)

But just a heads up, I don’t think it will make a difference, because just to test, I downloaded 2.83 (which is not officially launched yet, I know) but even there, without any extra addons installed, except for the “mesh_hidesato_offset_edges”, it still crashes when using Offset Extrude with Interactive mode on.

Edit: yeah just tested disabling all addons except for “mesh_hidesato_offset_edges” and still crashes.

Edit: Tested with selecting a face instead of an edge, it also hard crashes. (Open blender, select cube, enter edit mode, select face, select Offset Extrude, crashes)

I have a laptop laying around, I can test there to see if it’s some type of hardware incompatibility.

To confirm that you are using the “right” addon
enable Edit > Preferences > Interface > Display > Python Tooltips.

When hovering over the menu item, you should see

 bpy.ops.mesh.hidesato_offset_edges... 

not

 bpy.ops.mesh.offset_edges... 

I used offset edge extrude (official addon) a lot these days and it is working for me in 2.83 alpha on Windows 10. Unfortunately not in the modal mode like in 2.79 but I have no problem with it…

1 Like

Hello everyone.
A question - we were working with Hidesato on Offset Edges addon improvements a couple of years ago, and we made an advanced version of it. We reached 0.4.0 version.
We added the ability to lock axis (for example, for making road borders)
Can it be updated instead of that one that is in this tread?

2 Likes

Hi.
Here is 0.4.0 version - latest by Hidesato.
Can you update that one instead updating 0.3.9?
mesh_offset_edges_1dInc .py (41.4 KB)

2 Likes

Correct

If you run Blender from Command Prompt, you may get the error message.

on windows:
shift + right click on the folder Blender.exe is -> something like Open Command Window
then run this command:
Blender.exe

Then see, if you have the message printed after Blender crashes

Update: I tested with a fresh install of Blender 2.82a on my laptop (windows 10 as well), therefore completely different hardware and blender installation. It still crashes the same, therefore it is not hardware related. It is also not version related (tested on 2.82, 2.82a, 2.83).

Running blender from command prompt gives the following message after the crash:

Error : EXCEPTION_ACCESS_VIOLATION
Address : 0x00007FF7B1BEF81A
Module : C:\Program Files\Blender Foundation\Blender 2.82\blender.exe

Also @helluvamesh , are you sure your addon have Interactive on:
image
and you are using the option from the menu:

Because right now I don’t believe it’s possible for anyone to NOT have this crash (at least on windows?), 5 people in this thread reported the same, using interactive/modal and offset extrude.
Unfortunately I can’t test on linux/mac to see if it’s OS related.

i tried to track down where it crashes and i don’t get it
after invoke’s return running_modal and before modal method iself

and i have quite random if it crashes or runs normal.

1 Like

I updated version 0.4.0 to Blender 2.82. Thanks for the new stuff!

Others should check, if this one crashes for them, too.

1 Like

Tested 0.4.0 here, still crashes.
What OS are you on helluva?

windows 7


It works nice with 2.82 official (Linux Mint)
Thanks! =)
What are conditions for crashing?

UPD, aw, interactive mode. Yes, it crashes in that case, but, honestly, I don’t use it, because perform architectural modeling, that requires numeric input most of times.

So are there people still maintaining and adding features to this addon?
Since the original author (I always thank him for this great addon) no longer updates the first message anymore, a new thread would be nice, for example “Offset Edges for 2.8” created by one of the people who is maintaining the addon. Thank you all by the way.

No, that features were added a years ago.
Basically, I ordered and funded them directly to Hidesato (an author), so I can understand why they weren’t released all this time. Now I shared them here.

It is a flashback, not a comeback.

3 Likes