Offset Edges

Do You use version that i’ve uploaded one post above?

1 Like

Yes and it works now thanks

Hi,
I love what you do!

I’ve fallen in love with Blender, it’s really great, and I’m willing to do anything to finally replace my Maya with it.

Unfortunately I don’t know how to code, that’s why I would like to ask you if it’s possible to improve your tool a little bit so that it can behave like Maya’s extrude.

Extrude Maya

Maya_Offset

Maya’s extrude is much more intuitive, fast and powerful with a Gizmo.

With that, it would be perfect ! Maya users like me could finally switch to Blender !

Is it possible ?

I would be super grateful.

Best Regards

1 Like

a component axis gizmo for move and extrude would be amazing. A simple thing that I miss often.

1 Like

Hi. I love this addon. Thanks so much :slight_smile:

Also is there an option if the offset extrude begins to overlap eachother, how would you solve this. Pictures included for my example.

3 Likes

I solved it by manually with “Face Loop Cut” and then manually deleting faces, edges, vertices. Then removing doubles and creating faces. Hope you guys get it.

Would be really nice if there was any option for faster or automated fixing.

I get a consistent crash:
Every time I try to use the ‘Offset Extrude’ while just trying to extrude a simple open line of a few vertices,
the crash log shows me this as the main error if I’m not mistaken:

> # backtrace
> Exception Record:
> 
> ExceptionCode         : EXCEPTION_ACCESS_VIOLATION
> Exception Address     : 0x00007FF6793405F3
> Exception Module      : blender.exe
> Exception Flags       : 0x00000000
> Exception Parameters  : 0x2
> 	Parameters[0] : 0x0000000000000000
> 	Parameters[1] : 0xFFFFFFFFFFFFFFFF

Any ideas? Can reproduce the error reliably, no matter the file.
Any open row of vertices will result in crash.

Please tell me if you need more information.

The workaround of course being: E, not moving the new verts, and then using ‘Offset Move’.

Blender: 2.90.1

Not working on 2.91. Not offset edges show up in the ctrl+e menu :frowning:

Are You using version that i posted few post above?

work in 2.91,But it seems that I can’t display the right-click window, but it’s enough. The best plug-in, I often use this important function in Maya. I can’t imagine how I can use blender without this function

1 Like

The .py script gorion103 posted works well enough. Thank you, a really nice feature that should be in Blender by default.

In my case in Blender 2.90 the option doesn’t pop up in the Edge menu.
Am I doing something wrong. Should I access to that option somewhere else.

Thank you for the great plugin.

Blender 2.91 has an add-on built in called Edit Mesh Tools. Just enable it and then access offset with CTRL-E in edit mode.

4 Likes

Hello @gorion103, Vert to Circle Modal is not working in Blender ver 2.91.2 ? Can you please update the addon ?

Work on 2.91.2

How to offset with curve profile?

Thanks so much for that man!
And apologies for the late response.

In Blender 2.9 I also experience crashes when I use Offset Edges > Extrude. But it’s OK when I go Offset Edges > Move (or Offset) and only change method to Extrude from Adjust Last Operation window.

A possible workaround is to go to Add-on Preferences and uncheck INTERACTIVE.
It will not crash then.

But anyway, cool if this could be fixed though. Even an error prompt would be better than a crash.

Thank you :slight_smile: realy helpful

Hello,

can someone make changes to mesh_hidesato_offset_edges.py addon to use scene units instead float number?
I usually use offset by mm and it’s not convenient every time typing values like 0.005 to offset on 5mm.

I only can make little tweak to the code to use precision=4 and step=.01, after that it can offset on 0.005 visually but real value can be 0.00487-0.00524 or similar…

Lines from 653

Summary
    width: bpy.props.FloatProperty(
        name="Width", default=.2, precision=4, step=.01,
        update=OffsetBase.use_caches)
    flip_width: bpy.props.BoolProperty(
        name="Flip Width", default=False,
        description="Flip width direction",
        update=OffsetBase.use_caches)
    depth: bpy.props.FloatProperty(
        name="Depth", default=.0, precision=4, step=.01,

0.4.1

Updated:
found how.
Just add subtype="DISTANCE", unit="LENGTH", precision=3, step=.01

    width: bpy.props.FloatProperty(
        name="Width", default=1, subtype="DISTANCE", unit="LENGTH", precision=3, step=.01,
        update=OffsetBase.use_caches)
    flip_width: bpy.props.BoolProperty(
        name="Flip Width", default=False,
        description="Flip width direction",
        update=OffsetBase.use_caches)
    depth: bpy.props.FloatProperty(
        name="Depth", default=1, subtype="DISTANCE", unit="LENGTH", precision=3, step=.01,
        update=OffsetBase.use_caches)

and it would be using scene units.

I can’t change visual value when you activate tool and move mouse, it write float value…
width_value
and what is B at the Angle value, misprint?
Lines from 907

    # methods below are usded in interactive mode
    def create_header(self):
        header = "".join(
            ["Width {width: .4}  ",
             "Depth {depth: .4}('A' to Angle)  " if self.depth_mode == 'depth' else "Angle {angle: 4.0F}В°('A' to Depth)  ",
             "FollowFace(F):",
             "(ON)" if self.follow_face else "(OFF)",
            ])

        return header.format(width=self.width, depth=self.depth, angle=degrees(self.angle))

It seems width=self.width should use my previous settings subtype="DISTANCE", unit="LENGTH", but it doesn’t.

Also it would be nice to have modal fine tweaking with ‘Shift’ holding.

2 Likes

bpy.ops.mesh.offset_edges(geometry_mode=‘extrude’, caches_valid=True)

I’ve been using this command/this tool for a while now, but is this a different version than this addon?

One thing I’ve noticed/just tested, with the version I use. If I have a subD Modifier and its Enabled, the edge offset performance definitely takes a bit hit/is lagging.

Maybe I can macro in my own addon/operator to temp disable modifier visibility/ offset edges then turn back on. But was am still curious about this version/if there is a difference.

That’s one I’ve been using:

image