Offset of amature in Pose and Object Mode?

Hello everybody!

I was just continuing to rig my character today and have an odd problem now.

In pose and in object mode, the master bone (and therefore the whole character) has a offset to the actual center of the amature. That means it is in a completely different position than the actual center.

Here is a picture of it:

http://img145.imageshack.us/img145/5359/offsetproblemeo7.jpg

As you can see the amature is far on the left and the center is far on the right (the small pink dot). Only if I go into the edit mode of the amature it jumps back to the position it is supposed to be.

How can I change this and get rid of this offset?
I’m guessing this whole thing happend because in the same project I created a walkcycle before (but now I wanted to rig it again and therefore bring the whole mesh back into its basic position, which I didn’t quite know how to do). So I’ve messed around a bit with the NLA Editor and the Action Editor, but I don’t really know yet how to work with them, so I guess the problem is somewhere there…

Can anybody help?

Thank you!

MD

did you try clearing any keys on the bones in pose mode, or even clearing the position, rotation and scale in pose mode.

The only way I can duplicate this issue is if I move the bones in pose mode and then switch to object or edit mode. Object mode stays at the pose mode position, and edit mode goes back to rest position.

Best suggestion if you haven’t keyed anything is to change to pose mode and select all bones[A] and then [ALT+G],[ALT+R] and [ALT+S]. That should move the bones all back to rest so that pose, object and edit mode they are all in the same place.

Hi bgstratt!

Thanks for you answer.
I forgot to mention that in fact I already did clear the position. I can manually bring back the character with moving the master bone in the correct position, but whenever I alt + G then it switches back and has this offset.

So it looks like I applied the translation or something like that. It is also possible that it has something to do with the NLA Editor or the Action Editor etc. How do I delete Actions for example, I would like to get rid of all these things to have a “clean project” file just with my rigged character.

I uploaded the .blend-file here:

http://www.2shared.com/file/2609290/c560edbe/cubegranny.html

Maybe somebody could have a look at it and find out what the problem is… (sorry for the upload page, I don’t know a better way to provide it…).

Thank you very much!

MD

I am going to guess that the fact you at one point did have animations and NLA strips applied to the armature is causing this weirdness … but you have deleted all the keys for the armature … the “fake user” actions still in the action editor have no keys either …

Your current file is bloated with IPO data (it’s too big for what is contained in it) and my guess is that one of the IPO curves has caused this … but since you have deleted all the keys which would have linked to this position of the root bone, I cannot think of a way to fix this … even if you append the armature into a new file the root bone still is still offset …

Unfortunately you might just have to remake the armature to get a “clean” file … unless you have a copy with the keys still intact …

And BTW the armature is rotated 90 degrees on the X axis . Most likely you added the armature object in the front view . Sometimes this can also create problems … you should always add everything in the top view if you want to avoid the rotation . Or Ctrl-A to apply it .

What you need to do to clear the offset is the following:

  1. Open a NLA-editor window
  2. Add a new NLA-strip for the armature (using Shift-A). Any one of the actions will do.
  3. Now, when you see the armature snap back, delete the strip.

I’m guessing that the cause of this problem is that the internal ‘offset’ value (of the armature) wasn’t cleared after you deleted the keys.

Aligorith

Hi Aligorith!

Sorry for my late answer and thanks for your advice it worked like a charm! Thank you so much for that, I was already afraid that I had to rebuild the whole armature.

@Vertex Pusher: Thank you also for telling me the armature was rotated, I fixed that now. I didn’t know you have to add everything in top view.

One more question is left: How do I delete the actions that are in my file? I just want to get rid of them to have a clean file.

MD

Hit Shift+F4 to get into Blender’s internal data directory -> hit the “…” to go up the directory -> go into “Actions” -> select all your actions (they will have a “F” next to them ) and hit F the F should be replaced by a 0 . Save and reload Blender and your actions will be gone . You might want to do this for the IPO data as well … Like I said your file seemed too big for what is in it .

Or you could just skip the above and just append all your objects into a new file … File -> Append or Link (Shift F1) -> open your file and you will see the internal data directory for your first file just like above . Go to the Object directory and select all your objects and hit Load Library or just hit enter and all your objects should be now in the new file . Save and you have a “clean” version of your project without a trace of animation data … This options comes in handy sometimes … Like when you can’t figure out how to fix some weird anomaly … and Algorith is on vacation that week :slight_smile:

Hi Vertex Pusher!

Thank you so much for your explanation. You probably didn’t know it, but you really saved my a**, because I urgently needed to know how to get my character into another .blend-file since I decided to use it in a project with a “christmas deadline”.

So thank you very much, I have a clean, clean file now. :slight_smile:

MD