.ojb model exporting issues (think this is the right place..)

Really wasn’t quite sure if this is the place where it’s supposed to go or not, oh well move it ;). Anyways I started a new project and exported the cube it default(ly?) makes as a .obj. So I load up a program I have, and import the model. It imports ok. Then when I try to apply a texture to it (in the other porgram), the texture doesn’t appear…anyone know why?
edit: I think that the reason it doesn’t load is due to “improper” exporting, so, I probably just need someone to tell me which options to include when I’m exporting it… and all of these .obj are wavefront.

What program are you importing into?

I’m importing into gamemaker, and inside gamemaker I can set the model’s texture. I’ll post the testing application in a sec. And, the example has around 4 different model types it can load, and it does successfully load the models (including a .obj) that came with it, as well as properly texture them, but doesn’t texture mine…will edit with a link

Edit:
Download link 1: http://rapidshare.com/files/3378417/model_loader.zip.html
Download link 2: http://download.35mb.com/dazappa/model%20loader.zip
What it is: model loader.zip
contents: 2 executables, each is programmed to load a different model.
cubeplx.obj
mosaic.obj
MY loader.exe
original.exe
info: this is for you to try and help me. original.exe loads mosaic.obj, and both of these are not mine. MY loader.exe loads, of course, my model cubeplx.obj. The texture it uses is inside the exe, and is many different colors. So, if under my loader.exe you get the model to be more than just white, and it has red, yellow, blue etc then you made it work. PLEASE: I just opened blender, kept the cube shape, and exported as a wavefront obj, there’s more than one type of .obj you can export. Only do wavefront as that is only what my program will load. Also, I think this problem may be because of what export options I have set, I have the default’s set. Program may take a minute to load. When you think you have a model you’d like to try, move it to the folder with my loader.exe and rename it cubeplx.obj. The app is only programmed to load cubeplx.obj. This does not contain any viruses, but if you’re really scared don’t download it :wink: If you need a different file format tell me. Only thing else I can add is .rar. And, if under my loader.exe you get it to load your model, pleease tell me what you did, like export options

dazappa,

My hunch is that in addition to the obj, your program also needs UVs.

Let try one thing first. In Blender, use the uv editor to unwrap your cube. This will have the effect of creating UVs for your cube without having to actually mapping anything.

Split your screen into 2 views. On the left, stay in 3D view, in UVface Select mode. Onthe right, change to UV/Image Editor. By default, all the faces of the cube will be selected, and in the UV editor, they will be shown overlaying each other.

In the UV Editor, click on UVs…Archimap UV Projection Unwrapper
Use the defaults. After the cube is unwrapped, in the 3d window, go back to object mode, then export the obj. When exporting, make sure the option to export UVs is selected (it should be on by default).

This is an example of a cube exported WITHOUT UVs

Blender v242 OBJ File: BuildingBlocks.blend

www.blender3d.org

mtllib ggggg.mtl
o Cube_Cube
v 1.000000 1.000000 -1.000000
v 1.000000 -1.000000 -1.000000
v -1.000000 -1.000000 -1.000000
v -1.000000 1.000000 -1.000000
v 1.000000 0.999999 1.000000
v 0.999999 -1.000001 1.000000
v -1.000000 -1.000000 1.000000
v -1.000000 1.000000 1.000000
usemtl (null)
usemtl (null)
s off
f 1 2 3 4
f 5 8 7 6
f 1 5 6 2
f 2 6 7 3
f 3 7 8 4
f 5 1 4 8

This is an example of a cube exported after going thru the steps I outlined:

Blender v242 OBJ File: BuildingBlocks.blend

www.blender3d.org

mtllib fffff.mtl
o Cube_Cube
v 1.000000 1.000000 -1.000000
v 1.000000 -1.000000 -1.000000
v -1.000000 -1.000000 -1.000000
v -1.000000 1.000000 -1.000000
v 1.000000 0.999999 1.000000
v 0.999999 -1.000001 1.000000
v -1.000000 -1.000000 1.000000
v -1.000000 1.000000 1.000000
vt 0.334353 1.000000 0.0
vt 0.333333 0.501529 0.0
vt 0.665647 0.500000 0.0
vt 0.666667 0.998471 0.0
vt 1.000000 0.501529 0.0
vt 0.998981 1.000000 0.0
vt 0.667686 0.500000 0.0
vt 0.998981 0.000000 0.0
vt 1.000000 0.498471 0.0
vt 0.666667 0.001529 0.0
vt 0.332314 0.500000 0.0
vt 0.333333 0.998471 0.0
vt 0.001020 1.000000 0.0
vt 0.000000 0.501529 0.0
vt 0.333333 0.498471 0.0
vt 0.334353 0.000000 0.0
vt 0.001020 0.500000 0.0
vt 0.000000 0.001529 0.0
vt 0.332314 0.000000 0.0
usemtl (null)
usemtl (null)
s off
f 1/1 2/2 3/3 4/4
f 5/5 8/6 7/4 6/7
f 1/8 5/9 6/7 2/10
f 2/11 6/12 7/13 3/14
f 3/15 7/16 8/10 4/3
f 5/15 1/17 4/18 8/19

Well, I did that, and this is what the file contains…

Blender v242 OBJ File: cubeh.obj.blend

www.blender3d.org

mtllib uv_cube.mtl
o Cube_Cube
v 1.000000 1.000000 -1.000000
v 1.000000 -1.000000 -1.000000
v -1.000000 -1.000000 -1.000000
v -1.000000 1.000000 -1.000000
v 1.000000 0.999999 1.000000
v 0.999999 -1.000001 1.000000
v -1.000000 -1.000000 1.000000
v -1.000000 1.000000 1.000000
vt 0.334353 1.000000 0.0
vt 0.333333 0.501529 0.0
vt 0.665647 0.500000 0.0
vt 0.666667 0.998471 0.0
vt 1.000000 0.501529 0.0
vt 0.998981 1.000000 0.0
vt 0.667686 0.500000 0.0
vt 0.998981 0.000000 0.0
vt 1.000000 0.498471 0.0
vt 0.666667 0.001529 0.0
vt 0.332314 0.500000 0.0
vt 0.333333 0.998471 0.0
vt 0.001020 1.000000 0.0
vt 0.000000 0.501529 0.0
vt 0.333333 0.498471 0.0
vt 0.334353 0.000000 0.0
vt 0.001020 0.500000 0.0
vt 0.000000 0.001529 0.0
vt 0.332314 0.000000 0.0
usemtl Material
s off
f 1/1 2/2 3/3 4/4
f 5/5 8/6 7/4 6/7
f 1/8 5/9 6/7 2/10
f 2/11 6/12 7/13 3/14
f 3/15 7/16 8/10 4/3
f 5/15 1/17 4/18 8/19

Now, my program won’t even load the model. I guess I’ll post a screenshot of the export options I used…which is the defaults I guess, and yes uv was selected…
http://i109.photobucket.com/albums/n59/dazzman_01/myexportoptions.jpg

dazappa,

Well, so much for my hunch. I am at a loss. You are getting the same results when you export that I get when I export. I have checked, and I can re-import the objects into Blender just fine. Just for the heck of it, make sure you can re-import the obj files into Blender. I have used the obj exporter/importer for a couple of other applications, (Poser, Daz, Bryce) and I don’t have a problem.

For what it’s worth, I had endless problems a while back trying to export obj’s, with all combinations of setting.

My partner was waiting for models in another app, and we ended up giving up on the idea, as so many strange things happened…

as if anyone had the time, it would be a great tute, as it it’s hardly mentioned in most places

I was talking to some people on the gamemaker forums, and one of them said if you don’t have texture coordinates gamemaker would make the model all one color. Anyone know how to add texture coordinates in blender to my model?