OK, I guess I don't get Radiosity rendering at all...

The idea behind the blend file I’m working on now, is to put a table floating in a box, with a plane emitting light above it, and a camera looking down at the table (and the shadow on the enclosing “room” box). Everything aside from the room box is inside it.

At this point, what I end up with is a radiosity calculation, and an obviously black rendering result. I’ve got the plane set up as an emitter, with the normal pointing towards the table.

If I’ve gotten the test blend file correct, all you should have to do to test this, is hit the “Render” button.


I’m fairly sure that I’ve made a mistake somewhere, but can’t seem to figure it out from the manual. Anyone?

The ambient parameter of the materials is zero. So they don’t receive light. Set it to something reasonable, like 0.5. The ambient parameter is equivalent to the ref parameter for diffuse reflection.

Setting ambient to 0.5 on the various materials seems to ignore the radiosity calculation as well, and I get pretty much flat gray shading instead of the shadows. Still not quite what I’m looking for :frowning:

If I use F5-Radiosity buttons “Collect meshes” with everything visible selected, and hit the “Go” button, I get a nice render, but only in the window I’m looking at, not in an actual “render” window. How is that “Radio” button supposed to work on the Scene->Render panel?

If it just makes the renderer do a radiosity calculation, and then throws it away, well, I must be doing something wrong… or maybe not. Help, please :wink:

So at least it isn’t black anymore.

A radiosity calculation does something that is called “Adaptive subdividing”. It subdivides the mesh where necessary. Radiosity rendering does not do that, you have to do manual subdiving - or even better - use subdivision surfaces. So to get a nicely shaded radiosity render, apply a Simple-Subdiv Subsurf modifier to the objects. Level 3 should be sufficient.

Cool, thanks for the help. I just tried a few more things, and think I’ve got it right …

For each radio-enabled surface I:

It appears that step 1 was not necessary. With the render settings in take3.blend, VColLight being on or off didn’t seem to make any difference in the results.

Once I’ve got a good handle on this, I’m thinking of updating the wiki Radiosity info to include how to use Radiosity Rendering without trying to bake it into a texture first.

If you use Radiosity Modelling VColLight is set automatically, because the result of the modelling process is “baked” into the Vertices (which is exactly what Vertex Color Light means).

Since nothing needs to be “baked” with radiosity rendering (it’s calculated on the fly), you don’t need VColLight.