Ok more discription

It says: cannot find program: blenderpublisher, when I either click on the file that is labeled blenderpublisher in the top directory of the extracted files.(currently located in… /home/tmp) I have also done the same procedure in the console as indicated in the official blender manual, (in the same location home/tmp). I think that the “my documents” type area of my computer is not the right place for these files to be extracted to and ran from. I found a tutorial for installing programs on mandrake that explains how to distribute the files on your own using the user/local/bin, user/local/lib, and so on, if the program does not come with a readme or configure file, which it looks like blender doesn’t. So just minutes ago I attempted this under root login (with pop up window warnings:this is dangerous!) but I kept a log of all the actions I took, and after finding that it still didn’t work, I undid those actions and I’m back to square one. This is everything I know about my situation. does this help? (thanks for sticking with me this far.)


I really have problems following your description.

I assume you are running Linux, right?

I hope you’ve got the right package for that. Which version of Blender
you dwnloaded? Is it Static or Dynamic? How did you install it?

I suggest first of all to use the Static one, unless you know what dynamic means.

Then you must verify that the current directory is in your path (’.’)

Otherwise the correct UNIX command to run a program is


or the fully qualified path /usr/tmp/blenderpublisher


There isn’t much to install.
Get the Static Blender Distro and decompress it somewhere.
Change to that directory in the console.
Do a long directory listing (ls -l) in that directory and verify that the file, blenderpublisher, exists in that directory and that it has executable permissions. If it is not executable than make it so (chmod +x blenderpublisher).
Now from the directory that the executable is in run it with this command:

It seems as you have the basics to learn about directories, file permissions, paths, and launching programs from the command line.

My version of linux is Mandrake Linux running with the KDE graphical interface. Which means I have tools like konquerer and an Install programs application( that will only install .RPMs that are on a list which is created by specifying a source(location) of the rpm) Blender isn’t an rpm it’s a tar.gz(not covered in my mandrake manual) which I found is just as popular as .rpm (so if I can’t figure out how to install them I’m in trouble) From what I’ve learned, In linux, programs don’t have thier own directory, the files associated with the program have to be distributed in the right location for the operating system to recognize them(I haven’t heard anyone comment on this aspect in this post so far). So far all I’ve done is download the tar.gz file with the name linux in it (the only installer with the name linux I might add) copied to a cd (I still have yet to get my internet to work on linux)from my dad’s computer, saved it to my own linux system in the directory home/tmp and I’ve decopressed it where it lies(to where it lies) by right clicking on the tar.gz file (in konquerer) and clicking “extract archive here” from the pop up menu (whether or not this qualifies as installation, I don’t know. But I doubt it), I then decided to check my official blender manual, and I followed every instruction while in the "konsole"after changing directories(cd) to home/tmp(home is a My_Documents like area)the result was the same as if I had selected the rightclick menu option “extract archive here”. And now I get the same result weather I go into the top directory with konquerer and left click the file blenderpublisher or go to the console and type ./blenderpublisher. A pop up window states “cannot find the program blenderpublisher”. And thats it, thats all I know, after tutorial hunting for the last 5 days. I hope somehing I said this time made somthing more clear, because it’s close to my last hope.

when I right click on blenderpublisher and select properties it is listed as an executable. I don’t know what this has to do with file permissions but I’ll try what you suggested anyway(in the “konsole”). Do you know of a way to set file permissions with a graphical interface? even though I am am going to learn the the extensive low level, comparable to programming( Ialready learned python) commands of linux, I don’t think it’s fair to force a regular joe user to do so who has a graphical interface and a box that promises “great for biginners” on what is suppose to be a standard for such users. But I guess thats an issue for mandrake to takle. I suppose I could opt for the online help I was allotted by purchasing thier distribution, but I didn’t think that’d be necessary for somthing as trivial as program intallation.

using chmod +x blenderpublisher did not solve the problem (and yes I am aware of what directory I’m in) I’m am curious about somthing stefano said : using the fully qualified path user/temp/blenderpublisher. I noticed that in this statementment blender publisher is not under a blender-publisher-linux…1.2.1-i386 directory as mine is, and mine is mot located under user/temp should it be ? just a guess. to be absolutely precise, mine is located under //home/chrisjengle/tmp/blender-publisher-linux…1.2.1-i386. while I periodically do state things in a way that implies I know what I’m talking about, I believe that what I do state I do know for sure, but beyond that I’m asking what should be a very basic question. And to those who would say i need to learn the basics of installing software with the tar.gz extention Iwould say: duh!? thats why I’m asking, thats why Ive been searching for the solution for longer that it would seem appropriate. Because I believe the question of: how do I Install blender on linux mandrake? is a question simple enough to be answered on a forum. While I’m not taking any of this personally(this is an awsome board and product) nor am I angry with anyone who has posted to my question(more like delighted) I am going to get very frustrated if it is suggested one more time that my discription of my situation is some how incomplete or blurred.

Oookkkeyy :slight_smile:

first point is: RPMs are RedHat and Mandrake standard for installation, all the rest of the word uses .tar.gz which is fully a UNIX standard ranging from Solaris to HP-UX to Linux and beyond.

What you did up to now looks fine, but I still need to know which tarball (nickname for a .tar.gz file) you’ve got. you’re sying your path is


This is funny because the numbers before i386 is the version number and should read 2.25, not 1.2.1. Anyway my static/dynamic question was superflous since I discovered in the meanwhile that only the static version is out there… at least I think so.

The correct way of istalling Blender is to unpack the stuff, like you did

For CHMODding right mouse click and properties->permissions do the trick

For running, I’d bet you cannot by clicking with muose, you should use a terminal. From that terminal, after changing directory to the one you have blenderpublisher in, you should try the command


This should work (i.e. works on my mandrake 9.0 :wink: )

Anyway welcome to Blender and Linux, you’ll learn that you have made one of the best choices of Operating System and 3D app, but this will take time. The fact that a Mandrake distro can be installed and in some way runs without need to know LINUX guts is nice, but when you’ll have learned those too you’ll relize how nice a OS it is


It says unable to open blender window when I try to run from the console. And the … ment I skipped up the 2.25 part of the file name (it’s to long to memorize, for me anyway). And are you absolutely positive the operating system will recognize blender as a progrm where it currently lies?

I assume you left X to go to the console, right?
However, you need to open a terminalwindow (kterm, xterm, whatever) on the desktop (on standard KDE installation there’s a nice button displaying a shell icon for it (~ 3-4 icon from the left in the panel in the lower part of the screen)). And there you need to execute the command to start blender.

Binaries can be wherever they want, it should not matter from where you start them and this is the case for blender as well as for most other progs. Only configuration files have usually a certain place where they have to be.
The trick with a preceeding ./ when you are in the directory of the binary should always work (well, as long as the rights of the file are set to allow it to you and - of course - if it’s executable).

I did everything you said. I guess it’s just a mystery then. It’s to bad cause blender was the only reason I bought linux, And I lost my Windows OS in the process( It was an upgrade edition(It wasn’t hard to forget,the only indication that it was, was a sticker on the outside sealed plastic of the box, long since discarded) and I figured I’d install linux first because Windows doesn’t have intuitive partitioning software. Boy was I suprised to find when I re-intalled windows it wanted an official previous windows os disk, which windows themselves claim it is illegal to sell a computer without one. But when I went to best buy they informed me that HP’s never come with a recovery disk, so I don’t know what the hell that’s all about, probably somthingelse illegal windows is involved in. So I have to either fork up another $200 to the software gangster, or find someone with the right disk, so far I haven’t achieved either. And now this. Well if thats truly it, thanks for your help anyway. I’ve probably frustrated alot of people with this post. it’s time to lay it to rest.

I really cant figure out the problem.

Can you follow these steps and tell us the results?

Open a terminal console

Go (cd) to the directory where blender is

Type these three commands and tell us the output:

echo $PATH
ls -al

ops, they were four…




pwd : /tmp
echo $PATH : /user/x11R6/bin:/user/local/bin:/user/lib/jre-1.3.1_04/
ls -al : (produced to much to copy, I took a screen capture but could’nt convert it to fat32, I’ll have to email it to myself later)
./blenderpublisher : bash: ./blenderpublisher: No such file or directory.
(It states this even though it appears in konquerer as: blenderpublisher)
Your right about the rpm thing you said earlier, I guess mandrake is actually easier than I thought it would be. besides this of course.

Here is what happened to me. I was running Mandrake 8.2 with the Nvidia drivers installed. Downloaded the BlenderPublisher tar.gz and unarchived it to my home directory. And clicked on the BlenderPublisher and it worked great.

Now I changed to Mandrake 9.0 and I get the results chrisjengle gets. Says its not found.
Tried ./blenderpublisher at a console and it said there were some shared libraries could not be opened because they did not exist.

I also have been trying to get filmgimp to work and Mandrake didn’t have the right glibc installed. Only Redhat has the right version.

The biggest problem I have with linux distros is, if the program didn’t come with the distro, its a real challenge to get it to work.