Ok seriously...

WHAT is blender’s problem with a transparent image???

Here I have an edge that fades to alpha 0, yet it stays at 100% opaque, fading into the sky color until the alpha value is exactly 0%, at which point it is 100% transparent, no sky color. The GLSL preview gets it right… WHY THE H*** doesn’t BLENDER???

Sorry if I seem a bit cross, but I’ve spent the last half hour dealing with this idiodic problem that should have NEVER happened in the first place!

EDIT: I’ve gone through 3 different file formats (PNG, PSD, TGA) and every time, blender always insits on adding that [email protected]$$ white border, and I KNOW that is not on the image in photoshop, I took extra precautions after the 100th save…

Attachments


press the stencil button in the map to tab on the shaders panel

It would really help if you would post the blend file including the image.

Well, obviously it’s an elaborate plot to drive you mad.

Calm down buddy. This is a standard problem. Unfortunately you haven’t supplied enough info to solve it definitively. I would suggest packing the image in a blend file and posting that.

(Have you tried ray transparency If so is TraShadow on? Is the image premultiplied? etc. etc.)

BTW premultiplied images behave differently in the renderer than they do in GLSL display.

Looks like you just need to check ‘Premul’ in the Image tab of the Texture buttons menu.

Aww geeze! That’s the button I was looking for last night! I could never find it though, and I wasn’t even really sure it existed anyways. Thanks man.

Sorry about my temper, it was late, and that one little thing was holding up progress.

Using the stencil option works for just one layer, but I had 3. I forgot to mention that.

Thanks to everybody for your speedy replies! :smiley:

Yes, Blender should press that button by default when it detects an alpha channel.

It is more the norm than the exception.