Old blender files to open

Hi,

I have a few old 2.49b .blend files which I would like to open again on my current Ubuntu 18 laptop.

So, I download and tried a several linux versions from blender.org site below but none of them work.
https://download.blender.org/release/Blender2.49b/

The ubuntu0904 file try to make installation via Ubuntus app. but gives error message about depencies.

The linux-glibc236 file extrac ok but the exe file is not working even I give a executable permit.

Any hints to solve this problem?

Thanks!

Does blender run at all, or does it only crash, when you open the old files?
The way you phrased your post isn’t very clear.

I think you can open 2.49 files in any newer version. Maybe try the latest Blender version?

Hi Kehlim,

And thank you for your kind answer.

The problem is, I can’t install or start the 2.49b version at all. I tried the 2.49b ubuntu and glibc files from the archive.

The 2.79 version, installed via Ubuntu software, runs nice and smooth.

The need for the 2.49 version is the old BGE file I made back in the day. I would like to show my kids old game and talk about the programming in general.

BR

Blender.org seems to be down at the moment so I can’t check, but I’ve run the Windows 2.49b version under Wine before and recall everything worked.

Edit: gave it a shot. Here it is in all its glory.

Hi. What depencies error exactly? Have you installed “libjpeg62” package?

Install “libjpeg62” package on Ubuntu. Download 2.49b:
https://download.blender.org/release/Blender2.49b/blender-2.49b-linux-glibc236-py26-x86_64.tar.bz2

Extract to a new folder. Enter to this folder and execute (double click) on “blender” file.
If it still does not work for you, you run in terminal “./blender” and share here the messeage it shows.
Here on Kubuntu 18.04 it works correctly.