Old Blender releases segfault on newer OS X

I’d like to run Blender 2.6 on OS X 10.10. Just to go through an older tutorial series. But I’ve found older releases all segfault on launch. (current release runs just fine) The blender wiki has build instructions on Mac for 2.7, but not older releases. And a cursory search indicates there was a problem with Yosemite crashes around 2.73ish that was fixed with a patch, whichy - who knows if it will apply to 2.6.


Has anyone here successfully built ancient releases on modern MacOS X? Am I going down a rabbit hole here?


I think you should be fine using the newer version instead. Not much has changed in terms of the UI. There may be better ways to do things now, but obviously an old tutorial couldn’t teach you about those anyway.

Has anyone here successfully built ancient releases on modern MacOS X?

Probably not.

Am I going down a rabbit hole here?


Thanks for the reply.

I tried that first. This tutorial series is the old cgcookie animation fundamentals set. It covers such things as bouncing ball, squish and stretch, character walk cycles and throwing a ball. Loading the first exercise I noticed the example ball animation was off. So that’s why I started down the path of trying to get an old release going.

This kind of material isn’t widely covered. Most of the stuff you find is on modeling, uv mapping, rigging, and weight painting. Sebastian Lague has a good tut on doing a walk cycle and run cycle with his ‘hat man’ series. But I’ve done that and feel I’m missing more fundamental stuff.

Regardless, I think I’ll need the older release to get those examples running properly. Or I’ll need to find out what’s broken (which may be a good learning experience itself).

You should identfy the crash reason in the log. I suspect something with fsmenu. Try disable iCloud and/or the “all my files” finder sidebar feature. Those typically broke older apps as they are not locations but search algorithms behind.


When I’ve tried old versions they crashed on startup. If i recall they would work if I disabled iCloud in the finder.

And Jens:

That did the trick. The older release runs after updating my Finder prefs. Thank you both very much.

Richard, do you tag these as “Resolved” or something? Or is there a way I should do it?