Old deleted data haunts me

I have an annoying problem. All my pre-rigged Spender Alien still have all deleted WeigtPaint ? I select at Object Mode my Spender Alien and Shift down, select the rig and with Ctrl + P automatically select the weight paint. At Pose Mode I drag one leg (arm) but other things follow with. I (delete) all of Vertex Group (All) and now finally also delete my armature (the rig) and start a new project by making a new blendfile with a new name. Still, everything from the old stuff is left in there. It makes me crazy. How can I restart from beginning with just my SpenderAlien on the screen without the old stuff.

Here is blendfile 1 The bad one. http://www.pasteall.org/blend/5494

Here is the latest one
http://www.pasteall.org/blend/5492 , clean from everything. New name Lurifax1, no bones/rig. No weight paint. Still, if I rig him up with brand new bones and new names at the bone and I use Ctrl+P automatic weight pain, I am back to the same problem and place as in blendfile 1.

I don’ like Blender remind me of old deleted problem at new projects.

Can you advice me.

Thanks in advance.


hello, i had a quick look and i had a similar problem. the automatic weights have attached weights to the body of the model because of the proximity. if you go to the alien itself then the modifiers panel there will be an entry for the armature. if you deselect the envelope goups but leave the vertex groups selected then you will have to manually clean up the vertex groups by re-weightpainting the problem areas. unfortunately i dont know of an easy fix for this. only thing i can suggest to help in the future would be when you make a model to have the limbs extended to help reduce the need to clean it up afterwards.

Only explanation that I can find is that armature is not completely enclosed within the mesh. When applying armature, select automatic weights (providing the armature is completely enclosed) and disable envelopes from the armature modifier.

Thanks for helping. I am confused by my self. I have rig up alien before and have more problem today than before.

I have clean up my (alien) blendfile from bones, old names, and have left only one modifier tool. Subdivide (not selected)

Here is the new empty blendfile lurifax2_blend http://www.pasteall.org/blend/5497

and here is same file with bones lurifax3_blend http://www.pasteall.org/blend/5498

Blender make me mad. Exact same problem as the first one.

I run at iMac Intel 10.6.6 64 bits and Blender 2.56 64 bits r35130


Have you tried appending to a new file? Just append the object to a clean blend.

P.S. I guess this is the new animation support forum after all…

I think I found the problem…took me long enough… it’s the mesh’s normals. Remove the armature modifier, un-parent the mesh from the rig, jump into edit mode for the mesh, select all, recalc normals (ctrl-N), then re-parent the mesh to the armature.

A few things I noticed: the mesh & armature objects don’t share the same origin, and the armature object has a scale of .153 to it, the scale should be reset with ctrl-a -> apply scale. Both of these are area that can cause problems. Also of note, move the armature modifier to the top of the modifier stack, that way it is evaluated 1st, before the subsurf modifier. If the armature modifier is below the subsurf modifier then blender has to deform 4x vertices when posing. It’s better to have the mesh deform first and subsurf the deformed mesh, less work for your computer.

Oh, and the support section for problems is a bit lower in the forum, you’re posting problems to the finished animation section…


edit: oh yes, I used the file with the bones in it, and I didn’t delete the vertex groups… Also uncheck bone envelopes from the armature modifier, and in the armature panel as well to make sure bone envelopes don’t interfere with deformation.

Sorry if this is wrong place for my problem.


Yes, you solve my problem. I recalculate with ctrl-N and uncheck bone from armature modifier.
Thanks for helping.