old set up ?

what files or folders do you need to copy from 2.74 to 2.75
to get old set up ?

I tested the composite glare
and not even close and not like halo!

thanks
happy bl

startup.blend and userpref.blend
If you have added a config folder in your …\Blender2.74\2.74\ , just copy them into your …\Blender2.75\2.75\config\

If you have not added a config folder, no idea where blender move those 2 files in your OS, i have always used the config folder thing, just make a search on your system for either startup.blend and userpref.blend and it should tell you where they are for your 2.74

on win 64
not certain how it is organize any more

some files seem to be in the app folder
like that userpref.blend
but the config folder is the program folder

and I did not create any config as I know of

how do u create this config folder
is this from the user pref window may be ?

did u test it for 2.75 if u are on win 64 ?
I was unable to get the recover thing

and now seem there is also a bug in nodes editor
some nodes are out of view !

thanks
happy bl

I don’t use the recover function, so i can’t say if it works, i either just copy my startup.blend and userprefs.blend from a config folder to another (useful when i use several buildbot builds), or simply redo my user prefs and startup, what i just did for 2.75.

how do u create this config folder
is this from the user pref window may be ?

Just create a new folder in your …\blender2.75directory\2.75
and name it config :
http://i.imgur.com/jQ2kokv.jpg
This way when you will use your blender 2.75 , every user preferences and startup blend file will be saved will be saved inside of that config folder…

looks like the set up is not the same on win 64!

hope they get a new release for 2.75 soon

thanks
happy bl

Hi

I run Win 8.1 64 bit. And use Buildbot…Unpack to My Blender folder…Run blender-app.exe

Blender make a folder in C:\Users\Ejer\AppData\Roaming\Blender Foundation\Blender\2.75\config
It’s where You have Your file as Sanctuary say’s…)

If You haven’t turn on Show hidden files You can’t see the AppData Folder in Your users\Your name Folder…

Blender update the folder when a new version is loaded.

Hope this help a little…Puff Puff

Tai

already done I see all files on win 64 !

and as I said the 2 files are not in the same location

some files seem to be in the app folder
like that userpref.blend

but the config folder is the program folder

look into you program folder
there is also some blender things there !

up to 2.74 the config was probably done with the recover command

but with 2.75 for some reason it did not work

also did you have any problems with nodes editor
some nodes seems to be out of view and cannot zoom all

thanks

happy bl

Don’t know if it make any difference…But…I have never used the installer version…Don’t know if the install version make a config folder
in the program folder…In My Blender folder there aren’t any config folder…Only datafiles - python and scripts folder.

blender-2.75-b05cf04-win64…Make a Config folder in User/bla bla…Where My startup.blend and userpref.blend are saved.
With all addons and other settings from earlier version.

Hmmm…Tried different node big and small all looks like they work fine here…Zoom work too.

Tai

anyway i’m getting win10 next month so I will wait to redo another install from scratch and see what happen !

thanks
happy bl

If i remember it’s not the 1st time you post about problems with Blender files and addons getting mixed on your computer
Same as Taipan mentionned, i never used the installer myself, so maybe considering you’re using it and always have troubles, there may be a problem between that installer and where it put the files on your system.

So use a simple solution : do not use the installer version, get the zip version that you can just extract where you want, same as if you get a buildbot version, and then make a config folder where i showed you, much easier and you will never have to search for the file anymore.

most of the time the recover did work fine
but some times there are things that don’t work as expected !
usually these are bugs which are removed and then it works fine
so it is good to check first if other peoples have same problems then report as a bug.

if u don’t install bl then how do you make your icon for blender files
work when you click on bl files in folders
how do u get it to open these file?

only way I found was to have main bl installed

unless there is a trick to open bl files without having a bl installed?
and even if there is this might be some hack !
I heard that you could modify OS registry to do that
but I prefer not to touch that which might end up with many other problems on win

I could also on occasion have some local build if there are interesting features available in daily build!
and usually these work fine too

will see if there is another official release soon!

thanks guys

To Open a Blend file…Right click it - select - open with - click - more options - Scroll down - click - look for another app - Find Your blender-app.exe…Not the blender.exe…And it should work.

I re-read Your first post…I think when You update to a new officiel Blender release…First time You start Blender there are a box on splash screen.Where You can tic to apply Your User preferences…If You don’t do it here You have to do it manually…Hmm…)

Not sure on this Im pretty new so take it with a grand of salt…)

Tai

that is what i did to do the recover
as I did on all the other bl version

but this time for whatever reason it did not work!
suspect this was a bug for win 64!

I redid most of my set up manually !

and working ok for now

thanks

There are some script utilities

python console output.


bpy.utils.
              blend_paths(

              modules_from_path(
              preset_find(
              preset_paths(
              refresh_script_paths(

              resource_path(
              script_path_pref(
              script_path_user(
              script_paths(
  
              user_resource(
>>> bpy.utils.resource_path(
resource_path(type, major=bpy.app.version[0], minor=bpy.app.version[1])
.. function:: resource_path(type, major=bpy.app.version[0], minor=bpy.app.version[1])
Return the base path for storing system files.
:arg type: string in ['USER', 'LOCAL', 'SYSTEM'].
:type type: string
:arg major: major version, defaults to current.
:type major: int
:arg minor: minor version, defaults to current.
:type minor: string
:return: the resource path (not necessarily existing).
:rtype: string
>>> bpy.utils.resource_path('USER')
'/home/batfinger/.config/blender/2.75'

>>> bpy.utils.script_path
                         _pref(
                         _user(
                         s(
>>> bpy.utils.script_paths(
script_paths(subdir=None, user_pref=True, check_all=False)
Returns a list of valid script paths.
:arg subdir: Optional subdir.
:type subdir: string
:arg user_pref: Include the user preference script path.
:type user_pref: bool
:arg check_all: Include local, user and system paths rather just the paths
   blender uses.
:type check_all: bool
:return: script paths.
:rtype: list
>>> bpy.utils.script_paths(check_all=True)
['/home/batfinger/GraphicApps/blender/2.75/scripts/modules', '/home/batfinger/GraphicApps/blender/2.75/scripts', '/home/batfinger/.config/blender/2.75/scripts']

>>> 

interesting but not following here can you elaborate

what does it do ?
is it equivalent to the recover command in splash screen ?

what this line do ?
bpy.utils.script_paths(check_all=True)

is it for checking what the default path is for the script path ?

I known there was some major revamp for saving user preferences about 1 year ago
and it was split in parts
but have not really found how it works now on win64

and win10 is coming next month so I will update and have to re install everything

I 've also redone manually my set up and now seems to work fine

I don’t change much on the bl set up only a few little things to make it more user friendly for my taste
but guess it is the idea of having choices which is nice feature

eX: viewport Rotate and pan I change the 2 keymap !

thanks
happy bl