One cylinder will snap to target. Another won't

Can anyone tell me why I can make the flat face of the small cylinder parallel to a face of the cube and I can’t make the large cylinder do the same?

Test2.blend (883.8 KB)

For the small one the object normal is the same as one of the cylinder sides… for the big one not…
(You can see this if you enable the move gizmo and change the transform orientation to Normal)

You seems to have rotated the big one in edit mode ??

Edit: just have a look a the Z-axis of the normals:

1 Like

You appear to be right. So, how DOES one transform an object’s mesh such that one of its faces is parallel to a face of a second object, regardless of their object normals? Alternatively, how best to reorient the mesh of the first object such that the chosen face is the same as its object normal? Or does the question belong in another post?

You cylinder has a special geometry so this might not work as you might expect. but:

In edit mode select to flat face and add a custome Transforamtion Orientation, set cursor to selected and add an empty. Use Object → Transform → Align to Transform Orientation… (from the cyl. side) parent the large cylinder to the empty, select the empty and snap the empty to your cube face… now you can delete the empty…


Mesh align plus can do that.


I can use it to orient the mesh relative to the global Z using an edge of the mesh, but then I need to set the transform orientation to the global too (to its default?). Don’t know how to do that.

Edit: If I just join the mesh-aligned object to a new cube added in object mode (which has a default transform orientation orthogonal to its sides), then that zeroes the transform orientation.

In the case you described, to align two different objects faces, you have to select the cube first and then in face edit mode, you selet the target face and click under “quick align planes” the “grab destination”. Then you swich to the big cylinder and select the bottom face, and click under “apply to” on “object” to align it. You can also use the same method to align it to a ground plane so that you can reset/apply the transform. ( Menu->Object->Apply-> AllTransforms)

I hope that helps. :slightly_smiling_face:

1 Like

Yes, that appears to do it all in one swell foop. By far the simplest solution. Getting the Mesh Align Plus addon installed was another matter though, until I finally realized that the directory containing evidently can’t be in a subdirectory.

1 Like

:hushed: :grimacing: :face_with_head_bandage: :expressionless: :expressionless: :expressionless: :expressionless: :expressionless: :expressionless: :rofl:

I find that, even when using the Mesh Align Plus addon, it fails to align a circular face of the cylinder to a cube face in the attached. But if I select all and un-subdivide the cylinder, it does align the two faces. I assume the failure is due to an assumed maximum number of vertices or something?

Test3.blend (841.8 KB)

Hmm yes indeed there’s something wrong with it. The addon has quite alot align options, but hasnt been updated for a long time, maybe it needs a fix.

Anyhow you can use “Attach align” instead. Select two objects, go to edit mode select both faces (order is from…to) and use “Attach align” from the context menu.

1 Like

If you’re an old guy like me and got imprinted on the earlier Blender RMB select convention and manually changed BACK to the RMB convention at ver ~3, then that will cause RMB to fail to invoke a Context (right-click) Menu and thus ‘Attach Align’.

You say you have no context menu? And what happens if you press “w”?