One image output for each render layer


(patrickp78) #1

Hi,
In my Render Layers nodes, I added a file output to the image output of each render rayer to automatically save each render.
In the end, it always records the first render but not the others.
Does anyone have a solution?
Thank you in advance,
patrickp78!


(kesonmis) #2

First thing to check: do your file output nodes write out to different paths? Maybe you duplicated your node and forgot to change paths so one render result overrides others?


(patrickp78) #3

Bingo! Many thanks.
My problème now, what to do to avoid to decrease first image after a second render?
Is it possible to ask naming image.1 image.2 image.3 …
The overwrite option in output doesn’t walk… checked or not
Thanks for your help
patrickp78


(kesonmis) #4

Point each File Output node to different path and problem solved. Open the node properties panel (on the right side of node editor window, N shortcut), set Base Path to folder where you want this input saved and in File Subpath field add file name.


(patrickp78) #5

Sorry, but I don’t find where is my mistake.
I added a file Subpath name “Composite”, I tried “Composite.001”
Every time it delete the old one to replace it by the new one.


(kesonmis) #6

Maybe I’m not understanding what your problem is…? Does one renderlayer output overwrite other or do you mean new render overwrites previous? You are only showing one file output node settings, show the others too. By the way, by clicking on Add Input button in settings you can add more inputs to node and write them all conveniently out by setting appropriate subpaths. Subpath can contain subfolder names also, not just file name.


(patrickp78) #7

Thanks for your help and please excuse me if my explanations (due my english) are not clear.
In fact, the render layers operation is ok. After rendering, I find each image layer render and the final composite image in their folder and the image names are ok as you told me to do in the Subpath.
The problem now is that when I make a now render, the new images delete the old ones and take their places in the folders, instead of keeping old ones and save themselves with a new indice .001, .002 etc


(kesonmis) #8

There is no automatic file name versioning so I’m afraid you have to set these names manually in your case. Easiest way to do this would be by using one file output node and put version number into main path. This way you only have to change number in one place.


(patrickp78) #9

OK, it’s perfect like that!
With Subpath, I refind all my images in the same folder,
I just have to increment the folder name in the FileOutput to keep the previous images.
Many thanks to you for all your advices.
patrickp78

File%20Output