One massively annoying change with Blender 2.8: The New Undo system

If you have any of the problems below, make sure “global undo” is ticked on the settings.

Blender 2.8 is great, from big things like EEVEE to the normal editing tools to even subtle change like not having to confirm when saving, 2.8 has made definitely made my job as a freelance game artist easier

Everything from the beta feels like a final release, with one exception. the undo system

I don’t really have a problem with it being unified, in the blender 2.79 nightly builds, I can see what the working version of this undo system is supposed to look like. And it’s fine.

But the implementation of this feature in 2.8 just breaks the entire experience. It barely works as intended.

Sometimes it just crashes randomly when I undo and the real issue, it doesn’t register anything outside of edit mode, so you can’t actually undo anything you do in object mode, you can’t undo applying modifiers, you can’t undo adding objects, you can’t really undo anything.

It’s getting to the point where I have to save a different blend file every time I do something that I think I might have to undo.

Why is no one talking about it?


CPU/GPU: AMD Ryzen 5 2400G (though it had the same issue on my old g2030 + r7 240 build)

Ram: 2 x 4 GB Crucial 2133 MHz DDR4

Blender Build : 01 - 17 - 2019

Hmm, I can do all those things, in object mode works fine here. We even have an undo history where we can go to a specific point in the history, which seems to work ok also. My build is for Linux 64 Bit from 2019-01-15, I tested with default settings (blender --factory-startup).

1 Like

Even an undo history huh? Sounds like I might have an issue, I’ll add my specs on the thread

Is the shortcut for undo history still the same?

I do not recall having issues with object mode undo not working here, though I do keep fairly up to date with builds.

The new undo system does have its own quirks, but one of the things it tries to fix is the major issue of possibly losing a whole session’s worth of changes if you undo past the point of exiting another mode (such as sculpt mode).

Ah, it looks like “Global undo” is on by default in more recent builds.

Apparently that was the culprit.

Yes, “Global undo” is on.

Undo history is under Edit in the main menu, it doesn’t show a shortcut, might not have one by default.

“Global Undo” has caused issues for me in blender 2.79, because, somehow, it switches from enabled to disabled. I suspect there’s a shortcut key assigned to it, and maybe I triggered it.

My default setup has GU enabled. It didn’t get disabled by any conscious action I took. Sometimes, later, I would get the no-undo-history issue, and eventually find that it’s only the GU option, somehow disabled once again.

That’s caused by a faulty add-on. It’s a common mistake to disable global undo temporarily but not take care to restore it in case of unexpected errors.