One side of my object is invible

Just created a rose pedal, but It’s invible on one side, I think this has something to do with the normals, but I don’t even know what they are. How do I go about making my 2D shape (in the 3D world) visible from both side?

use uv editor and
set “two sided”

Ignore the above post… it says nothing, this option is not in the “Uv editor.”

To get into the face settings, go into the editing buttons (hotkey f9) and then hit “F” to go into face mode, select the face you want to two-side, and then click the “two-side” button. If you have multiple faces that need this done in the same object, select them all with key A, and then hit two-side, and hit the “copy drawmode” button.

I have many problems with the materials in the engine. Everything else works, but he materials look awful. I tried using just regular colors even and pressed “Make Vert Color” in the edit menu. It still doesn’t work.

The problem is, that sometimes it will get really dark or really light and it’s not because of the lamps or shadows or anything like that.

ANd yes, I made it two sided and the normals are facing the right way and I’ve tried it all.

Faces that are invisible? I think you mean faces facing the wrong side, also called, flipped normals.

This is a typical thing in blender. It mostly happens when you place the vertices yourself and fill it useing F or something else. The option to make it two sided it a really bad idea. Two-sided is only being used for single faces like grass, hair on characters, windows or something else. Using on all objects tw-sided because faces are invisible is the worst thing you can do. It causes fps drop on big scenes, as well that lightning will look really weird, because those flipped faces cause instead of shadow side, a light side and reversed.
You have to flip the normals by hand or let it do automaticly.

1: Automaticly

  • select opbject
  • go into face selection mode
  • select all
  • hit tab to get into face selection edit mode
  • hit ctrl + N and the rest is logical

2: manually

  • select object
  • go into face selection mode
  • select the invisible face
  • hit tab to get into face selection edit mode
  • hit in edit button (F9) window the button “Flip Normals”

I think that will help, else you didn’t fill those faces or it’s a bug :stuck_out_tongue:
But I’m sure it helps. :slight_smile:

That works for the other guys problem, but “invisible” faces isn’t mine. It’s that the faces are different shades of the material (like really dark or really light).

You have smoothen the mesh on which you’re applying lightning and material on? Try to subsurf the model, set smooth, and turn off subsurf again. And check, else can you post a screenshot? :-?

Actually I think it might be a lighting problem after all. Is it possible to have faces emit light good Because I’ve tried the “emit” and it didn’t work well.

I still can’t get it to work properly.

You see, I’m going to have a few helmets on a bench, and the player can see right through them.

See the attached file:
http://hyphenex.ugtech.net/Armour.blend

Many thanks, Scott

Just as everybody has been saying on this thread, you have 2 problems:

  1. Some of your normals are facing inwards instead of outwards. Corrected by Ctrl+N in edit mode with all vertices selected.

  2. You need to enable Two-sided faces if you want to see both sides of the face. Corrected by enabling ‘twoside’ in the face select options then clicking ‘Copy Drawmode’ with all faces selected in Face Select mode (F).

Here is a link to the corrected file: http://www.freeuploader.com/download.php/56721e84f88660feb7bfeb25ba8a8026.html

Keith. 8)