Only Shadow Texture Blocks Shadow Pass In Render Layer

Hi All,

I just ran into the most unusal thing while I was building a node setup so I could fade in the amount of shadows in my final render.

Take the default cube scene and add a plane. Move it down one unit in the z-direction so the cube is sitting on top of it. Scale it up a bit (in the top view)and add a light to the scene so it casts the cube’s shadow onto the plane. (Lamp-Sun-Shadows enabled)
Open up a nodes window, select Composite Nodes (little picture icon) and then turn on the Use Nodes button. You should get the default three node setup.
Click the Render Layers TAB and add Shadow to the Render Layers Pass.
Now, add another render layer and name it “No Shadows”. Add the shadow pass to the render layer and then CTRL-LEFT-Click on the shadow layer button to remove shadows from the combined output.

Add this render layer to the composite nodes window and add a mix to set up your scene like the image below.

Render the scene and everything works fine. The overlay node controls the mix of the shadows in the final scene.

HERE IS THE BUG:
Select the plane that catches the shadow and add a material to it and click the “Only Shadow” button and re-render your scene. You will see that the “No Shadow” layer has added the shadow pass back into the scene and there is no way to remove it.

The second image shows the result of the node window after a re-render with the only change being that “Only Shdow” was turned on in for the plane material.

Is there a work around for this?
Can anyone verify this BUG?

Attachments



You can do the same effect, if you set the material alpha to “0”.

Happens for me too, when I follow your steps. Maybe I don’t get what you are trying to do, but you can fade the shadows on the Shadow only object by adjusting it’s alpha value.

There is a problem with blender using ShadowOnly and reflection, they don’t work together. So I was looking for a work around.

Try this, add a plane and make it shadow only, then turn on reflection for that plane and you will see what I mean.
If I fade the alpha of the plane, my reflection will fade too. I want to be able to control the softness of the shadow independently of the refelction strength and have it all still have an alpha.

This seems “undoable” in Blender at this time. Anyone have a workaround?

This is mainly to facilitate icons for the “web 2.0 wet floor” look.

What blender really needs is a “RelfectionOnly” companion button just like ShadowOnly.