OnlyShadow spotlights


(Kid Tripod) #1

hi
i take it many of you know about the annoying dark rings with onlyshadow spots, and i seem to remember that some version of Blender doesn’t have them. if so, how do you do get rid of them?

thanks


(S68) #2

Yeah,

they are truly annoying.

They are generated, At least I think, by a buggy implementation of the decrease in light intensity toward spod boundaries.

What I do to get rid of them is:

A - I don’t use shadow only spots

B - If I must use them a maximum value in BufSize combined with a very careful placing of ClipStart/ClipEnd, a quite high SpotBl and a not so high Samples and soft settings yeld decent results.

Hope this helps

Stefano

P.S.

have you tried the recipy?


(VelikM) #3

Try adjusting the ‘Bias’, set it to a higher number, increase the ‘Samples’, and try to adjust the ‘ClipStart’ and ‘ClipEnd’ values to the min required for the scene.