Open GL 3.3 in blender 2.8 Alpha 2

Hi guys,

I’m trying to use Blender 2.8 alpha 2, but everytime i try to open the computer says that it requires at least OpenGL 3.3 graphics driver. I don’t have much knowledge on this stuff, is there anything i can do to fix it?

I really wanted to try this version, if you guys can help me i would be very glad :smiley:

1 Like

What GPU do you have? If you don’t know, post what operating system you use and we’ll help you figure it out.

Blender 2.8 requires a GPU with OpenGL 3.3 support. For AMD, that would be a Radeon 2000 series or newer (aka, an ATI Radeon 2000 series. All the GPUs actually branded “AMD” instead of “ATI” support OpenGL 3.3). For Nvidia, that would be the 8000 series or later. Note that for both AMD and Nvidia, pretty much all products from the last 10 years are supported.

For Intel integrated graphics, you need something a bit newer, an HD 2000 graphics (bundled with Sandy Bridge CPUs)

1 Like

Here’s my computer specifications:

Windows 10
Processor: Intel ® Core™ i5-2450M CPU @
2.50GHz 2.50 GHz
Installed memory (RAM): 4,00 GB
System type: 64bit

So far as I can tell your processor’s integrated graphics are Intel HD 3000 for which the OpenGL version is 3.1, which isn’t high enough. So if you don’t have a separate graphics card you would need to get one. However the processor seems to be a mobile so if your system is a laptop you are probably out of luck.

Your GPU is an Intel HD 3000, which has hardware support for OpenGL 3.3, but Intel never shipped driver support for this on Windows. I’m afraid you will need to stay on 2.79 or switch to Linux until you are able to get new hardware.

See https://www.katsbits.com/codex/will-blender-run/

okay, thanks guys :confused:

Paolo_Di_Luca try this code [ --debug-gpu ] (add to your launcher on windows) on linux use terminal and complete path to blender.

example windows: blender.exe --debug-gpu

example linux: ./blender --debug-gpu

note: (your binary path may be different, adjust accordingly.)

1 Like

blender

Like this? i did it, but now i don’t know how to execute it.

Create a Short Cut in a folder or on Desktop afterwards open properties on Shortcut and place into the target location points.

Make sure the " marks are present after the code is input, make sure to click apply to update the blender shortcut. View graphic i upload for refrence hope this helps.

If this version :: your-path-blender.exe --debug-gpu" doesn’t work try
Alternative :: your-path-blender.exe " --debug-gpu

If Still No succees may have to update Hardware. AMD Ryzen is best choice.

1 Like

It didn’t work, but thanks for the help anyway.

Hi. I have same problem in 2.80 BETA with the build from 16th of May 2019.
I added the trail to the shortcut and the answer in console is:

GPUTexture: create : TEXTURE_CUBE_MAP, RGBA16F, w : 2, h : 2, d : 0, comp : 4, size : 0.00 MiB
GPUTexture: create : TEXTURE_1D, RGBA8, w : 1, h : 0, d : 0, comp : 4, size : 0.00 MiB
GPUTexture: create : TEXTURE_2D, RGBA8, w : 1, h : 1, d : 0, comp : 4, size : 0.00 MiB
GPUTexture: create : TEXTURE_3D, RGBA8, w : 1, h : 1, d : 1, comp : 4, size : 0.00 MiB
Using OpenGL 4.3 debug facilities
GL application marker: Successfully hooked OpenGL debug callback.
Win32 Error# (3221692624):
Win32 Error# (3221692624):
Win32 Error# (3221692624):
Win32 Error# (3221692624):
Win32 Error# (3221692624):
Win32 Error# (3221692624):
Win32 Error# (3221692624):

That is saying to me, that I already have at least OPENGL 3.3. As you can see suports 4.3 as I have 2GPU’s GTX 1080 TI up-to-date as I’m writing this post.

I’ll appreciate an solution from you, guys. Thx

The thing that all you need to do is so simple and this method gives 100% success

Step 1 - download and install the blender 2.8 stable version (master version)

Step 2 - download this opengl32.dll compressed file from this link

http://downloads.fdossena.com/geth.php?r=mesa-latest

Step 3 - extract this mesa.7z file and copy that opengl32.dll file and paste it in your blender 2.8 destination folder.

Bamm now open blender 2.8 you will see the miracle.

If you have any doubts in installation comment to me.
I’ll do my best…

This method was from

1 Like

It worked!

1 Like

BAM!! Indeed, thank you Felixzs!

1 Like

thank you it work but it can not render by evee

1 Like

i have same problem…
its say unsupported graphics card or driver.
i have last update driver but not work
My laptop spec:
i5-2430M HD 3000
Nvidia GT 540M 2GB
10 GB RAM
windows 10 pro
please help :frowning:

previous i use windows 7 its work but after i upgrade to win 10 it error I do not want to downgrade my windows .