OpenEXR Multilayer--No Alpha

Hi, all.

So I am using Bartek’s workflow of rendering an OpenEXR Multilayer image sequence and pulling that into the compositor. I’ve done some work in the compositor, but when I get to the final product, I’ve noticed that there is no alpha channel anymore. I’ve tried pulling the “combined” pass into the “Composite” node’s alpha socket, I’ve tried running it through a “Set Alpha” node, and I’ve tried the “Map Value” --> “Color Ramp” --> “Composite” combination. Nothing. Where did the alpha go? There is no separate Alpha socket on the “Image” input node like in the “RenderLayer” node, so I’m at a total loss here.

There is no separate output socket when you add input image with MultiLayer EXR rendered from blender, but it doesn’t mean it’s missing. Alpha channel is present in some of the passes, especially in “Combined” output.
If you want to access the alpha channel you have to “Separate” channels, so use “Separate RGBA” from “Convertor” section. There you have the access to all 4 channels: Red, Green, Blue and Alpha.

Sure enough, that did it. Thanks, Bartek!