Opening 2.59 game in 2.49

I created a game in blender 2.59 which worked when I opened it in 2.48. However, if I open the game in blender 2.49 and press “P” the mouse disappears but game doesn’t start and the screen remains the same. I don’t know why a 2.59 game would start in 2.48 but not in 2.49, you would think it would be the other way around :confused:.

EDIT: So when I start blender 2.49 in Terminal and run the game it says that the game is starting and running properly and ending when I press Escape. For some reason it’s not showing in the viewport.

who cares no one uses 2.48 any more and most people use 2.5 so why does it matter.

well, there has been massive changes from 2.4 to 2.5 regarding blender rna/dna which is well reflected on the blend files. you can try appendind models, the script part and animation part is not reverse compatible.

Because GLSL (for normal maps, shadows, reflections) works much faster in 2.49 than in 2.5+ versions on my computer.

@Blender Fan - Not to derail the topic, but how much faster is ‘much faster’?

The Blend files are not backward compatible. I wonder that you can open a 2.5 file in 2.49. I always get an error and it is not opening.
Do you append the objects?

Both ways work for getting the .blend, but neither gets the game working.

For example, a setup in which a buffered spot lamp casts a shadow onto a plane (using GLSL) runs at 60.00 fps in blender 2.49, but only 1.90 fps in blender 2.59.

i do not know what is wrong with your computer because 2.5 is faster on my computer.

That sounds exceedingly wrong. Try setting the draw settings in the User Preferences panel in Blender 2.59 - I know that Blender was unresponsive to certain draw types for my computer awhile ago. The setting is in: File > User Preferences > System > Window Draw Method.

which settings is the best for faster processing,the tripple buffer or full? sorry if that sounded dumb but i dunno which one is better!?

Try both - see if either works, and if so, go with it. Also, try a recent build of Blender off of GraphicAll.

To open a modern blender file in an old version of blender, and then get the game to play (assuming no scripts) you have to go to the render buttons and de-select “sequence” and “compositor”

I tried each of those settings but it didn’t seem to make a difference.

Hm. How high is the buffer size for the shadow set in 2.5? Try lowering it. Also, see if it’s the core Blender executable - just place a cube in the middle of the scene, set it to GLSL, set Framerate and Profile on, and play. See how fast it runs, and compare that to 2.49.

The buffer size is set to 2880 by default in both versions. I can get it to run faster (8.50fps) in blender 2.59 by lowering the buffer size to 512 (the lowest possible value). The setup with a single cube runs at 60 fps in both 2.49 and 2.59.

Try Enable All Frames, as well, on Multitexture mode - this really sounds off. Also try upgrading your graphics card driver. As 2.49 is older, it might use older OpenGL function calls, calls that your graphics card supports. However, with the upgrades to 2.59, it’s possible that the graphics calls have become newer, and that your graphics card is having trouble running it.

That’s probably what the issue is. Oh, well, I guess i’ll just have to stick to making games in 2.49 for now. Thanks SolarLune for helping me figure this problem out, it has bugged me for quite a while.

You don’t want to upgrade your graphics card driver? Even if it doesn’t help 2.5, it could at the very least speed up 2.49. You might want to try it out, or try out a newer build from GraphicAll or an older build from the Blender Foundation homepage.

Thx SolarLune i tried both and honestly i cant see the difference so i leaft it as triple buffer