OpenSubDiv is on its way back

news

(erickBlender) #41

Yes i was talking about Multires. and of course wanted to test subsurf as well.
@lucky I believe it is the window lib is not updated yet, so we have to wait :slight_smile:


(English is not my native language) #42

But compared to 2.79, fps are almost the same to quality=1, but in solid view. In material view fps falls to half in 2.79, and here in 2.8 I am using eevee and material with SSS (same fps in solid view in 2.8).

Edit:
When I mention 2.79, I am referring to default subsurf without OpenSubdiv.


(Ace Dragon) #43

Multires sculpting is starting to come back, and in an improved state based on the new code.
https://lists.blender.org/pipermail/bf-blender-cvs/2018-September/114218.html

There’s a few limitations yet such as no sculpt propagation between the different detail levels, but this is still in a heavily WIP state.


(Ace Dragon) #44

There has been a lot of under-the-hood work on Subdivision and Multires this week. This has now led to user-visible changes such as being able to sculpt at lower levels which propagate to higher ones.
https://lists.blender.org/pipermail/bf-blender-cvs/2018-September/114470.html

It works for masks as well.
https://lists.blender.org/pipermail/bf-blender-cvs/2018-September/114483.html


(xrg) #45

Is there a flag or something to enable it? Multires modifier doesn’t work in sculpt for me.


(Ace Dragon) #46

I think there is a developer flag to enable it, with how to do that buried in the commit logs.

This might be something that can be done only at the compiler level though, I don’t think it will be enabled in the buildbot builds until the implementation is in a fully working state.


(English is not my native language) #47

I remember in a commit from a week ago that Sergey had mentioned that this was not enabled by default for this not to affect studio production. I tried to find the commit but it is difficult, there are a lot of commits by Sergey per day…


(xrg) #48

I think I found it here.

I built with OpenSubDiv, but I don’t seem to have the WITH_OPENSUBDIV_MODIFIER=ON option. Turning debug to 128 doesn’t seem to do anything, either. Oh well. I think he’s supposed to be finished with it relatively soon anyway.


(English is not my native language) #49

Yes, that was!
I am compiling with the modifier flag ON right now in Linux. What I’m not sure is if with 128 debug value should then appear a menu as with debug value 256.

Edit:
Yes, I can go to sculpt mode now. I first search for debug menu and entered 128 value, then added multires modifier.
About “WITH_OPENSUBDIV_MODIFIER” flag, I use cmake-gui in linux. I search “opensubdiv” word and enable the three lines that appear with the opensubdiv word.