OpenVDB remesh

Thank you for the excellent support.
It now all works great!
FYI I lowered the default resolutions in the script as I found it lags when opening.

Is it possible to run this tool programmatically? E.g. from the Blender Python console or even from the command line? That would be an enormous advantage.

Glad to hear it’s working out for you.

You can run the addon programmatically something like this (for example):
bpy.context.scene.openvdb_settings.voxel_resolution_world = 20 bpy.ops.object.vdbremesh_op('INVOKE_DEFAULT')

The toggle for “Values from panel” must be on. If you turn on the Python tooltips in Blender you can see the paths for all the values by hovering over them.

Love this add-on. I do have issues using the latest 2.8 build where the menu keeps dissapearing at, what seams, arbitrary moments:

Hi, I couldn’t replicate this problem. Could you copy & paste the following: import platform as p; import bpy; "|".join([p.machine(), p.platform(), p.python_version(), p.python_compiler(),,]) into Blender Python Console and tell me what it prints out.

Does the problem exist in other operators that have value adjustment in similar fashion?

Hi ambi,

I just bought the addon. I’m trying to use it with Blender 2.8 beta from 2019-04-19 on Ubuntu 18.10. I followed the installation instructions carefully and I can enable the addon but then I cannot find the feature in Blender. Nothing shows up if I search with space bar and there is no menu option anywhere. Could you please help?

The Ubuntu version of 2.80 wasn’t done yet. I uploaded to Gumroad which should have all the required files. The install process is the same as the previous one, but you also need to sudo apt install libopenvdb5.0 to get all the required libraries.

If you have already installed the previous package:

  • Close all running Blender instances
  • Remove openvdb-remesh folder in Blender addons folder, and replace it with the new one
  • Copy all the files in the libs folder in the zip to /usr/local/lib and run sudo ldconfig
  • Replace the in the Blender modules folder with the one in the zip file
  • Run sudo apt install libopenvdb5.0
  • Then start blender and turn on the addon

Holy crap, talk about quality support. Works perfectly now, thank you!!!

have a bug with Gaussian Iterations on 2.8 - vdb_remesh_b2.80-ubuntu
(vdb_remesh_b2.79-ubuntu worked fine)

Traceback (most recent call last):
  File "/home/bm/.config/blender/2.80/scripts/addons/vdb_remesh/", line 326, in execute
    self.vdb_settings.filter_width, 'blur', self.vdb_settings.filter_sigma, grid=self.grid)
  File "/home/bm/.config/blender/2.80/scripts/addons/vdb_remesh/", line 110, in vdb_remesh
    return (_write(grid), grid if saved_grid == None else saved_grid)
  File "/home/bm/.config/blender/2.80/scripts/addons/vdb_remesh/", line 105, in _write
    gr.gaussian(filter_param, filter_width)
AttributeError: 'FloatGrid' object has no attribute 'gaussian'

location: <unknown location>:-1

scripts has same openvdb libs, right?

The new package contains different and libs. You have to replace the old ones with the new ones. At first glance it looks like you’re using the old libraries with new Python scripts. I can’t test it right now but will get back to you later if you still have problems with it. The proper installation process in in my previous post in this thread.

Thank you.
Can you give me a link to your openvdb fork or patch?
my build was from

The Github should be the latest. If you look at line 2890, you can see the function your error message complains about.

The Gumroad .zip should also contain all the required libs already compiled.

Hm, I tried to install new version of the addon, form, and it doesn’t seem to wanna be installed. That’s after deleting whole 2.80 prefs folder:

Redist is installed, any solutions?

UPD: It was solved by unzipping the archive into the addons folder bypassing install from the Blender itself.

Hey ambi! Having a blast with the add-on so far. One small bug to report. I can not Export my KeyConfig if I have a hotkey assigned to the OpenVDB Remesh button. Steps to reproduce:

  1. right-click on OpenVDB Remesh button in the VDB Remesh panel, and assign any shortcut.
  2. Go to User Preferences, Keymap, Export, and try to save the file.

This is the error that I get:

It’s not a big deal, but I’m trying to narrow down another issue I’m having where my main selection hotkey randomly keeps getting changed to something like view3d.select_more_or_less or something. If anyone knows why this could be happening, I’d appreciate the input.

I have one more question: is there a pop-up window that I can call for the tool, instead of using the N-panel on the right? I have been using a hotkey for remeshing, because I like to remesh pretty often so I prefer to quick access similar to the ease at how you can dynamesh in zbrush with ctrl drag off the model. However, I am unable to control the resolution exactly when I use the Remesh hotkey. Sometimes the resolution might happen to be too low and I lose all the details that I’ve been sculpting.

Thanks ambi!

Also, OpenVDB seems to reset the object origin at the world origin. Can this be avoided?

There was probably an old installation it tried to overwrite. If you want to install new versions, you need to close Blender and remove the folder manually before. It’s because Python captures the library and it can not be unloaded before Blender is closed, as that’s how Python modules work.

@z01ks Thanks for letting me know. Seems Blender keymap exporter doesn’t like to export PointerProperty. Setting and writing the keybind to a file would definitely be very useful. I’ll look into it.

If you remesh with too low voxel resolution, you can still change it in the operator setting window. You can also call the operator from the spacebar search menu and typing (for example) “reme”.

Setting the correct object origin after the remesh process shouldn’t be too difficult, I’ll add it to my to do list.

1 Like

Hello, please add possibility to enter voxels resolution over 1000. I trying to remesh small meshes using relative mode. can’t get more than 680k polys
Or maybe i’m doing something wrong :face_with_raised_eyebrow:

vdb_remesh_1.6.6_b2.80-win64 is up on Gumroad.

Should fix the following issues:

  • Can’t remesh more than 1000 voxel resolution. You can now change the maximum in the addon preferences

  • Object origin gets reset. The operator should now only reset scale, not other transformations

1 Like

thank you. could you update also fro 2.79 ?

Sure: vdb_remesh_1.6.6_b2.79-win64 @ Gumroad

Let me know if you have any further issues.

Thank you for this. It’s really really excellent!