OpenVDB remesh


Thank you for the excellent support.
It now all works great!
FYI I lowered the default resolutions in the script as I found it lags when opening.

Is it possible to run this tool programmatically? E.g. from the Blender Python console or even from the command line? That would be an enormous advantage.


(ambi) #305

Glad to hear it’s working out for you.

You can run the addon programmatically something like this (for example):
bpy.context.scene.openvdb_settings.voxel_resolution_world = 20 bpy.ops.object.vdbremesh_op('INVOKE_DEFAULT')

The toggle for “Values from panel” must be on. If you turn on the Python tooltips in Blender you can see the paths for all the values by hovering over them.


(PolyGreen) #306

Love this add-on. I do have issues using the latest 2.8 build where the menu keeps dissapearing at, what seams, arbitrary moments:


(ambi) #307

Hi, I couldn’t replicate this problem. Could you copy & paste the following: import platform as p; import bpy; "|".join([p.machine(), p.platform(), p.python_version(), p.python_compiler(),,]) into Blender Python Console and tell me what it prints out.

Does the problem exist in other operators that have value adjustment in similar fashion?


(ant1fact) #308

Hi ambi,

I just bought the addon. I’m trying to use it with Blender 2.8 beta from 2019-04-19 on Ubuntu 18.10. I followed the installation instructions carefully and I can enable the addon but then I cannot find the feature in Blender. Nothing shows up if I search with space bar and there is no menu option anywhere. Could you please help?


(ambi) #309

The Ubuntu version of 2.80 wasn’t done yet. I uploaded to Gumroad which should have all the required files. The install process is the same as the previous one, but you also need to sudo apt install libopenvdb5.0 to get all the required libraries.

If you have already installed the previous package:

  • Close all running Blender instances
  • Remove openvdb-remesh folder in Blender addons folder, and replace it with the new one
  • Copy all the files in the libs folder in the zip to /usr/local/lib and run sudo ldconfig
  • Replace the in the Blender modules folder with the one in the zip file
  • Run sudo apt install libopenvdb5.0
  • Then start blender and turn on the addon

(ant1fact) #310

Holy crap, talk about quality support. Works perfectly now, thank you!!!