Orange "Phantom" Lines

Hello, Advanced beginner here; first post to Forum. Having issues with deleting part of a mesh that is highlighted in orange (see attached). I don’t know what the orange lines represent - bevels, creases, or how I inadvertently I created them? Also, you’ll notice there is one face highlighted on one side which I’d also wish to delete. Thanks in advance!

Kevin

Attachments


I can only guess without your file, but that looks like a separate object that is selected but not active, and has edges with the face deleted, just like the part in the active object. To delete a face select it and press X. To select a face select all the verts or edges or the face dot depending on which mode you are in (see the 3Dview header)

You may not know that there is a manual online that deals comprehensively with these beginner’s steps in Blender. Link.

Do not crop window - show as much as you can, including relevant parts of interface. Here that would be Modifiers tab, Outliner window on selected Object and so on. Read about HowTo and Why
C
ould be something duplicated.
To delete that extremely narrow face on the right in image ( i do not see any selected face but i see black square on the edge) delete double vertices and adjust Merge Distance value on Toolshelf bottom part right after you W - Remove Doubles.

I think that’s a vertex where it shouldn’t be (vertex mode view)…

Could be vertex as well… Need moar spectacles :D.

Anyhow - where’s the file? Or link to it on pasteall.org?
If rules do not permit direct link in text - type it without http part. We’ll figure.

Well after posting my question last night, I went to bed. The next day, I opened up my Blender project and apparently it had changed or “transformed” into a new arrangement as seen in the attached image. Since I’m not versed enough in Blender, I can’t speculate what was the initial problem, but it “seems” Blender may have fixed it for me. As you can see, the four vertices that constitute the present orange, “phantom” face were usable and my problem is solved. DruBan, I did consult beforehand with the online manual you mention, but wasn’t really able to narrow down what my issue was. Needless to say, there is a vast amount of information to be learned, something which I try to everyday. Thank you all for your help!

Attachments


Seems Blender resolved the issue for me when restarting my project the next. How, or why that occurred, I have no idea, but as you can see, the four vertices are usable now. Thanks for your help!