Orbit View and Turntable / Trackball option do not work as described and expected

Hi,

I just make my first steps in Blender and I have a problem with navigating with keyboard shortcuts.

With the numpad keys I can move up and down, to the left and to the right and I can rotate around an object but only in the up and down direction. I didn’t find a way to rotate around an object in the left and right direction.

The numpad 4 and 6 keys only rotate the object so that the object stays in the current view. But I cannot move around the object.

I tried to change the orbit style in the user prefs from Turntable to Trackball and backwards but there was no effect.

How can I enable the horizontal rotation around an object? No tutorial I read does mentions this (wiki.blender.org, www.blendercookie.com, www.katsbits.com)!

Well, I don’t use a keyboard, but the keystrokes to navigate with a mouse are as follows:

Hold down Middle Mouse Button to Rotate.

Scroll Wheel OR Ctrl+Middle Mouse Button to Zoom.

Shift + Middle Mouse Button to Pan/Dolly.

(With Num Lock on) 1 on the NumPad puts you in Front (Looking from the Y Axis) Orthogonal view, 3 on the NumPad puts you in the Side (Looking from the X Axis) Orthogonal view and 7 on the NumPad puts you in Top (Looking from the Z Axis) Orthogonal view. Ctrl+1, 3 or 7 puts you in the inverse Orthogonal view for that button.

0 on the NumPad will put you in the Camera view.

That’s pretty much all the basic navigation controls I use. If you don’t use a mouse, I’m not sure what the commands on the keyboard are, but I’m sure they can be found in the User Preferences window under the Input tab somewhere (Probably under 3D View)

Please do not create new threads for the same question, it doesn’t help other users who may have the same problem and is discourteous to anyone who replied to the original question. I’ve merged your two threads together.

If I read you correctly, it sounds like you are in top view of your object and are using the numpad 4 and 6 keys to rotate object.

Have you tried to change the view using the numpad 1, or 3, or 7 keys first, and THEN use the 4 and/or 6 keys to rotate.

Should work. :spin:

Absolutely right. I am in top view of my object and I am using the numpad 4 and 6 keys to rotate an object. But these keys rotate the object in such a way that I always see the same side. Having my top view I want to walk around the object in small steps so that I can investigate my object step by step. With numpad 8 and numpad 2 I can do that in the up and down direction. I want the same in the left and right direction. (Look at your smiley in your posting! THIS kind of rotation I want. At the moment I only have a clockwise and counterclockwise rotation like you have it in clocks. Unfortunately this site doesn’t have the corresponding smiley!)

Why I should at first use the numpad 1, or 3, or 7 keys?? Numpad 7 makes no sense at all here because it shows the top view and I am already there. And numpad 1 and 3 changes the orientation of the view. It is now horizontal orientated after it was vertically orientated. That’s ugly.

Furthermore I want to WALK around the object, i.e. I want to change the view in smaller angles like numpad 8 and numpad 2 do that. Numpad 1, or 3, or 7 roughly change the angle by 90 degrees.

I simply want the numpad 8 and 2 functionality for the left and right direction. How can I get it??

You say you are FULL of light. Give me your light!!!

Why I should at first use the numpad 1, or 3, or 7 keys?? Numpad 7 makes no sense at all here because it shows the top view and I am already there. And numpad 1 and 3 changes the orientation of the view. It is now horizontal orientated after it was vertically orientated. That’s ugly.

I do not know what mesh object you are viewing and especially do not know in what orientation you have your mesh front facing, axis-wise, or if your mesh even has a front face (it may be a geometric shape of some sort - I dunno). Numpad 7 makes some sense if your object is say, the earth or sphere of some sort and you need the front face pointing in X or Y in some desired way.

Further not knowing your mesh or why it appears “ugly” in front (Numpad 1) view or side (Numpad 3) view, but, if the front of your mesh is along the Z-axis it will never rotate as I assume you want from top view. You must first rotate it some degrees (usually 90) and orient front face of mesh somewhere near or along X or Y axis, then, and only then will Numpad 4 and Numpad 6 do as you want in the orientation you want.

Note that these orientations are all relative to the object you have created and in which view you created it in.
Just try other views with Numpad 4 and 6, or try another object to get an idea as to what the view orientations and Blender operations on them do, this is the only way to fully understand why you can’t get what you need/want given your experience in the 3D graphics world.

I don’t “give” light, neither have I stated I am full of light, just take it as no one can ever come up smelling like roses all the time.

I am not looking for a rotation of “some desired way”. I think I really explained what kind of rotation I want. In my last posting I wrote:

Having my top view I want to walk around the object in small steps so that I can investigate my object step by step.

Does numpad 7 provide this kind rotation in any way if I am already in top view? If the top view was rotated around the Z axis then numpad 7 would reset this rotation. Does this move the view in any way AROUND the object, i.e. in this way: :spin: ? No.

I don’t want to rotate the view “in some desired way” but in such a way that I can WALK AROUND AN OBJECT. For that rotation numpad 7 makes absolutely no sense. It sets the view into the top view (by resetting a possible Z axis rotation) although I am already there as I wrote. (We always assume that I am already in top view as you wrote yourself.)

Numpad 1 and 3 are ugly because they perform two rotations although I only want one.

All this does not help in any way. If you want to help me then please simply try how numpad 4 and 6 work on your installation and tell me what kind of rotation you see: Do you have a rotation around the Z axis (in this case you always see the same side) or around the Y axis (in this case you walk around the object). If you see the same rotation as me then we at least can exclude a problem on my installation. If you see a Y axis rotation then we can figure out where the difference is between your and my installation.

perchance you have 0 degrees set in user preferences, interface tab. Check that out.
It is near the center of the window and slider control is labeled ‘rotation angle’
if you dwell with the mouse over it the tooltip will say it is for degrees/press of the 2, 4, 6, or 8 keypad keys. A 1 degree/press rotation is really fine step, but I don’t get why Blender users would set this to 0.

I think you’re misunderstanding what these key are supposed to be doing, numPad 1, 3 & 7 keys don’t ‘rotate’ the scene the way you’re thinking, what they do is re-orientate the scene to face a fixed direction, that is “Front”, “Right” and “Top”. So, if you’re in “top” view the scene will ‘appear’ to rotate (when in fact it’s re-orientating itself, there’s a difference) to face “Front” if you press “numPad 1”. That’s it, that’s all those keys do, ‘fix’ the direction.

Using numPad 4 & 6, 2 & 8 then rotates the scene relative to those fixed orientations, that is “left <-> right” and “top<->bottom”, that’s how you “walk around [a] model”, you fix your orientation and then rotate around that, so if you’re in Top view, of course all you’re doing is rotating around the top of the model, you need to switch to ‘front’ or ‘right’ to “walk around”.

Your model looking “ugly” in those views is probably due to your being in partial perspective and/or haven’t press “numPad 5” and/or have fiddled with the scene trying to get what you want making it all wonky when it’s rotated. But without a screenshot of what you’re seeing that’s a guess.

It actually sounds like you’re wanting to do what’s called a “turn table rovolve” around your model… just so you know, that’s usually done through animation, not keyboard controls.

Read Blender Docs under heading “Rotating the View” here http://wiki.blender.org/index.php/Doc:Manual/3D_interaction/Navigating

Explanations are given for trackball/turntable and Numpad keys also.

3 people have given suggestions for you, but if you persist in “walking” around your mesh
in Top view (Key 7) it ain’t gonna happen.

I read the Blender docs before I started this thread and I read it again now. I want to comment this doc a little bit because it does not really exactly explain how rotation in Blender works. Take it as a proposal to edit the doc.

Click and drag MMB on the viewport’s area: if you start in the middle of the window and move up and down or left and right, the view is rotated around the middle of the window. Alternatively, you can press and hold Alt while dragging LMB in the viewport’s area.

To change the viewing angle in discrete steps, use 8 NumPad and 2 NumPad (which correspond to vertical MMB dragging, from any viewpoint), or use 4 NumPad and 6 NumPad (or CtrlAltWheel ) to rotate the scene around the Z global axis, whatever being the point of view.

Concerning numpad 4 and 6 the doc is specific: The rotation is a rotation “around the Z global axis”. That means that this kind of rotation depends from the orientation of the global Z axis - and this orientation changes often as you work.

In particular this statement means: After numpad 7 was pressed the global Z axis points perpendicular in/out of the user screen. With this orientation of the Z axis the rotation is done in that way that the user always sees the same side of the object (clockwise or counterclockwise rotation). In almost all cases a user should not desire this. The user most often doesn’t want to turn a face, a body, a car or a landscape upside down. The user most often wants to walk around the object.

But after numpad 1 was pressed the global Z axis lays parallel to the vertical user screen edge. With this orientation the user can do what he/she most often wants to do: to walk around the object.

But the main problem is that the orientation of the global Z axis often changes and that the user must have a close look at the orientation of this axis in order to know what kind of rotation he/she will get with numpad 4 and 6 or with horizontal MMB. If the user does not watch the orientation of the global Z axis he/she will be surprised by unexpected rotations. This can a new user make crazy.

And what does the doc say about numpad 8 and 2 and about vertical MMB? Around what axis do these user actions rotate the object?

The doc doesn’t say anything about the corresponding axis. The reason is simple: A more precise description would reveal a fundamental inconsistency that most users will not suspect. Numpad 8 and 2 as well as vertical MMB do not rotate around any global axis but always around the view X axis (that lays parallel to the horizontal user screen edge). With this definition there is never a change in the way how vertical rotation will work. The global coordinates can have any orientation but vertical movement will always let the user walk around the object. This can a new user make happy.

This description considers only Turntable rotations. Trackball rotations I don’t consider here because this kind of rotation does move all global axis and no keyboard keys can perform it.

The doc should make the user aware that Numpad 8 and 2 and vertical MMB (or Orbit View Up and Down in the user preference settings) are bound to VIEW COORDINATES. Numpad 4 and 6 (or Orbit View Left and Right in the user preference settings) in the contrary are bound to GLOBAL COORDINATES.

Before I formulate a precise text for the Blender doc I still want to know if users can confirm the described behaviour. I already asked in my second and in forth posting if users can confirm the behaviour that I described. chip4brains wrote that 3 users have given suggestions for me. I understand this that this should show me that there is no configuration for a horizontal rotation that is independent from global coordinates. May be. But I still want a confirmation that rotation also on other installations works as I have described it here. For this confirmation I made a small CHECKING PROCEDURE:

  1. Activate turntable movement in user preference settings.
  2. Press numpad 7.
  3. Move with MMB horizontally or press numpad 4 and numpad 6.

On my machine the view rotates in that way that I always see the same side (rotation around the global Z axis or around the view Z axis). Both axis point after numpad 7 perpendicular in/out of the user screen.

This is NOT a desired behaviour.
Desired is: The view should rotate around the view Y axis so that I can walk around the object.

  1. Press numpad 1.
  2. Do absolutely the same as in 3)

On my machine the view now rotates in that way that I can walk around the object (rotation around the global Z axis or around the view Y axis) Both axis lay after numpad 1 parallel to the vertical user screen edge. Concerning the view coordinates the rotation axis is now the Y axis, not the Z axis.

This is a desired behaviour.

Please follow this procedure and let me know what you see.

You can move around the object because you’re no longer in TOP view, you’re in FRONT orientation. As was said above, all movement and rotation is relative to fixed orientations, it has to be otherwise you’d be using arbitrary systems that wouldn’t make sense to Blender.

As an aside where have you seen the behaviour your trying to describe above?

Correct, using Numpad 1,7,or 3 will rotate an object using global coordinates, but the only time this will give odd rotations is if your object has local coords that are not aligned with the global coordinates.
The docs are still correct because they state that rotating an object using the keypad keys are done using global coordinates, this orientation follows the convention of front, side and top that are accepted views when an object’s coordinates are projected into these views using a 45 degree ‘turn’ from top to side and a 90 degree ‘turn’ from side to front view. This is how classical architectural draftsmen and engineers made drawings. They could obtain many other views using different ‘turn’ angles but this then is not global coordinates but local to the object. Global itself is not consistent as some apply apply ‘up’ as the Y axis or others the Z axis. If I can find such a drawing I will post here.

Anyway if you want to step around your mesh and it has displaced coordinates from global (ie local) then you CANNOT use the Numpad keys to obtain what you want (unless there is some settings to change this, but I believe not), You must use the R key and mouse and restrict it to an axis by also pressing the X, Y or Z key. If you do not desire to leave your mesh in a rotation different from where you started (ie return to original orientation you had before using R key) then terminate your mouse moves by pressing the right mouse button. If you do want to keep your view rotation then terminate mouse movement using the left mouse button to confirm this.

Also, while rotating with your mouse, if you press and hold CTRL key you will rotate in whole increments and not fractional. Pressing and holding SHIFT key instead of CTRL will allow fine increment rotations. Also move your mouse while doing this in a circular motion.

Intention of the numpad key rotations is for viewing, not editing as the R key does, and should remain global, this is in case you have a scene full of many objects and not just one mesh.

@kat-II

Your question is really strange. You ask as if you don’t see this behaviour on your own computer. On the other side you explain the described behaviour as if there cannot be any other way.

Where I have seen the described behaviour? I see it on my own computer of course. I see it all the time and it makes me crazy. This is the reason why I started this thread.

Now I already asked the third time what other users see on their computer. What I must do that you perform the small 5 step CHECKING PROCEDURE in my last posting and tell me if you see the same on your computer or not? (I asked a similar question already two postings before my last one.) One possibility for the behaviour on my computer is that I have any wrong configuration or that I have a buggy version. Once again, I am using Blender 2.57.1 r36339.

And what are you telling me about rotation and fixed orientations? Don’t you understand that the question here is not that I believe that the orientations don’t have to be fixed but why they are fixed to different sorts of orientations?

The problem is: Vertical MMB is fixed to VIEW COORDINATES (most likely on all Blender installations). Horizontal MMB in the contrary is fixed to GLOBAL COORDINATES (perhaps only on my computer). And global coordinates change as I work so that I never know what rotation I will get unless I always keep track of the global Z axis. With vertical MMB I never have this problem because view coordinates are always fixed to my individual view. With vertical MMB I always get the same vertical rotation. With horizontal MMB I get different rotations (“clock like” rotations or “walk around” rotations).

And now please be a kind and lovely Blender user, check the small 5 step CHECKING PROCEDURE in my last posting and tell me if YOU see the same behaviour as me on YOUR computer. :evilgrin: I still don’t know if I have perhaps a problem on my own computer.

The default orientations in Blender are not “fixed to different sorts of orientations”, they’re fixed as has been described above by several people. The global coordinates system does not “change as [you] work” they always stay relative to the global environment, front/side/top. It’s always been like that for the reason chip said in his first paragraph above.

Upload a video or screenshots of exactly what you’re seeing (I don’t know why you didn’t do this in the first place).

Have you changed your “Transform Orientation” (the 3D header menu) to “View” instead of using “Global”?

That’s exactly what turntable navigation does: it treats the global Z-axis as special, with the XY plane as the platter of the turntable. If you want the MMB not to treat the global Z-axis as special, switch to trackball instead. (This setting only affects the MMB: keypad 4 and 6 always behave in turntable style.)

Best wishes,
Matthew

  • Yes, your request does the same in my Blender. Your’s is not broken.
    -Yes the docs are not robust …not yet. There is alot of revision being done for the 2.5x versions of Blender, it will be some time. The docs are a wiki - so find out how you can contribute. Or like most users - play around with Blender, explore, take notes, be prepared to learn as well as unlearn and maybe relearn with a different approach to the various tools, operations and 3D concepts.

Now to your original request to walk around your mesh in top view - have you tried the R key rotations yet? Do that, and note the Rotation operator panel that comes up in the Tool Shelf - here you can rotate to your heart’s desire in any restricted axis and with different properties set.

As said many times - walk around will NOT happen with the Numpad keys with top view only. You must use the different approach as given, or reposition your mesh to another view or close to another view.

Contribute to the docs, you have made some good observations that many have missed, mainly because Blender is still under construction, with many revisions and unavoidable bugs. Ranting at the finer details and docs is a lost cause for now.

Guaranteed, what you have now may not be tomorrow.