orbiting w/ Middle Mouse button

Hello,

I just loaded Blender 2.46 RC1 on my new Vista computer and when I press the MMB it does not orbit the 3D view. This worked when I had it on my XP computer.

Any Ideas?

Thanks,
Joe

What does MMB do in other software? Do you have any manufacturer (e.g. logitech) drivers loaded? If so you might need to go into their control panel and change the middle button to be the middle button instead of ‘autoscroll’ or ‘do backflip’.

For all I know, the vista mouse control panel has that built in, so check for button assignements there, too. All I know is anything that lets you assign the buttons, NEVER friggin defaults to plain middle button use …

If it dosn’t work otherwise, do you know about the alt-left option? It’s in the options panel somewhere.

Are you sure the user options are the same as on your XP? Draging down the top header shows it, here is mine:

Good luck!

Attachments


I have the View & Controls setup just like that. It still does not work. I think it is the hardware configuration but I can’t find anything for the middle mouse button. There are options for a right and left tilt of the mouse wheel but no regular click. And I have not tried the alt left option I would rather have it like before.

Thanks,
Joe

I had the same problem. I just figured out the solution. It was my video card. Nvidia. I set it back to factory default and it took care of the MMB not orbiting the view problem.

I have exactly the same problem: MMB won’t orbit or pan on Vista, but works fine on XP. Alt-LMB works for me, but it would be nice to fix the problem. technojoe, what kind of system are you running on? Could you describe your specs?

I, too, have that same problem.

Thanks so much for suggesting the Alt+LMB. It works…however, I’d still like to be able to get this to work as it should.

For reference, I’m running a MacBook with a Logitech mouse and when I press the MMB, the view toggles between 2D and 3D.

If anybody has some advice or suggestions, I’d appreciate hearing them.

Thanks.

My middle mouse button doesn’t work as usual with Blender. I find that strange because I’m using the Microsoft Explorer mouse with drivers that work with everything. There are a lot of options with those drivers like programming the mouse for different applications.

I think I’ve tried everything but I can’t get it to work.

Any ideas, or does anyone uses that same kind of setup with the working mouse?

(On Windows XP)

For what it’s worth, I just found out how to solve the problem for my Logitech mouse on the MacBook. Open the Logitech Control Center (found in “System Preferences” under “Other”), select the mouse, and press “Configure”.

Click on “Wheel Button” then select “Advanced Click” under the column labeled “Assigned Action”. Click the <alt> modifier (looks like a forward slash with a horizontal line in the upper right corner).

That’s what worked for me!

Got it to work and it changes the meaning of ‘usefull’.

Just check the pic attached.

Attachments