OS X zBlur?

Hi…

I did a quick search, and it looks like no OS X user managed to get the zBlur plugin to work…

Is there anything new on this subject?

No OS X users here? Wow! :o

No, that’s not so. But maybe they don’t deal directly with plugin source-code, compilers and such…

Maybe it means also that my supposition was right. There is no OS X user capable of operating that thing!

This shouldn’t go “un-noticed” I think… :frowning:

Ciao. :wink:

I’m an OS X user! And ya, I’ve seen the same thing as you. Apparently no one running OS X has managed to run the zblur plugin. Including me.

OSX here, too :slight_smile:

i downloaded XCode to mess around with compiling. however i have no idea HOW exactly, and the problem is i have no time for that either…

OK so we do have a problem! :o

I’m on OS X and did get it to work. Here’s what I did:

You need to have OS X’s developer tools installed for this to work.

Download source from here: http://www-users.cs.umn.edu/~mein/blender/plugins/sequence/zblur/zblur.c

The file zblur.c says to put the file in the plugins directory of the blender directory. Then it says to run ./bmake zblur. This didn’t work for me. I got this error:

ld: can’t open: …/…/blender.app/Contents/MacOS/blender (No such file or directory, errno = 2)
Link error

The …/…/ looks to me that it’s trying to go up one too many directories. So we’ll create an extra directory to get around this.

Within the plugins directory, make a new directory called zblur. Copy the zblur.c file and bmake file from the plugins directory to the zblur directory.

Open the Terminal and cd to the zblur directory that you created. Type in bmake zlbur (or ./bmake zblur). You should now have the compiled plugin named zblur.so.

To make sure that it works, follow this thread:
http://www.elysiun.com/forum/viewtopic.php?t=32750&highlight=zblur

Hope this helps.

bos you kick ass guy

when my teaching job is over today i will try this out.
not having zdepth in blender was always a pain for me.

i am not a coder i whish i would be but i am not.
i hope your trick works for me as well here on the G5s.

claas

can you upload your zblur build? unfortunatly i do not have access to install software on the macs here. so i cannot install and build it on my own.

claas

Try this link.

thank you so much!
now they only need to fix the blender app cause it does not refresh
the rendering when i change the model. the image always shows the old
rendering! it only changes the blur amount!!!

admin you should past a sticky that for os x users the zblur plug in works
finaly!!!

claas

No red images anymore!!! :°) Thank you!!!

Still no blur here, but now I know it’s my fault… I have to re read the tutorials! :smiley:

No… Doesn’t work…

I tryed Madcow’s tutorial, no “red” but I still have no zblur in the the rendered image… :-?

http://photozamulud.free.fr/no_blur.jpg

I got this result following Madcow’s tut.
http://boswellian.spymac.net/zblurtest.jpg

It rendered the complete un-blurred image first and then blurred it about 5 seconds after.

it works perfect here! check the console!
also keep in mind that blender for some reason does not
refresh the scene data in a proper way. i changed
settings and always got the same rendering, well blender
did not rerender it at all it just showed the old image.

and also set the clipping values for the camera!

claas

here is my rendering
http://www.jrkuhnen.de/zblur.jpg

i put a displaced map into it to increase the result.

claas

I did it 3 more times, but nothing…

Could you please try my version of Madcow’s file, and tell me if it works for you?

Sorry, I didn’t notice there was a new page in the discussion…

What can I do about that non refreshing problem? Even the saved jpg doesn’t show blur…

As for the cliping values, I think I used those in Madcow’s file…

hey

you forgott to set the camera clippingsta to a value that works.
in you scene it will be around 3.00.

than you will see a zblur effect only!

claas