OSA messing up my alpha channels!

I’m building a globe that has a modeled wireframe sphere surrounded by continents that are cut out with an alpha map (textured continents, if you will). When OSA is turned on (at any sampling rate) there is a rim of transparency around the modeled surfaces (the wireframe sphere) that are in front of the transparency-textured surfaces (the continents). This makes much more sense when viewed – please see the examples below:


Anyone seen this before? Any ideas? I’m stumped…

Turn on “Premul”, for the alpha texture, in the texture buttons window :slight_smile:

Guiseppe: thanks for the suggestion, but “premul” didn’t work. My alpha matte for the continents doesn’t have a real alpha channel anyway – I use the luma channel. The wireframe doesn’t use any images at all… (I tried it anyway, just in case, to no avail.)

Can you supply me the blend, and ill have a look at it ?

Okay, I made a new blend file that re-creates the problem. Render it with OSA and again without OSA. You may also want to turn off ZTransp on the larger sphere – this makes the problem go away (but doesn’t solve the problem, as then I’ve lost ZTransp!).

http://www.mostlydocumentary.com/images/OSA_Problem2.jpg

Having examined this more closely, I’m thinking it is a bug. Where do we send bug reports? Or can you come up with a solution within the current build?

Here’s the file: zTranspAlphaBug.blend.zip

Here’s a blend file: zTranspAlphaBug.blend.zip

This isn’t the one I posted earlier – I assembled this blend to focus in on the problem, plus it only uses procedural textures which simplifies things. You need to render the blend with OSA and without OSA, and compare (including alpha channels). You should also fiddle with turning ZTransp for the greySphere on and off – that eliminates the alpha issue, but also prevents me from seeing inside/through the sphere (which is what I’ve been trying to accomplish the entire time!). Here’s a sample of what my renders produced (v2.49, by the way, on OS X 10.4):
http://www.mostlydocumentary.com/images/OSA_Problem2.jpg

Hm… could it be a bug after all?

Sorry I didn’t notice this post earlier, but this seems to be the old Z-transp-edges bug (which already drove me nuts last year, when I started to work with blender!). There seems to be some fault deeply embedded in the combination of ztransp and OSA. You’ll probably find something usefull in http://www.blender.org/forum/viewtopic.php?t=14043 or its blenderartists-counterpart http://blenderartists.org/forum/showthread.php?t=141739 .

In short: It might be worth a try to use FSA instead of OSA. To do this go to rendersettings (F10)

  1. n the “Output”-tab activate “Save buffers”
  2. “Full sample”-button will appear, press that as well (->OSA will change to FSA then).
  3. Use FSA just like OSA, and don’t worry, if the image looks like it had no aliasing at first. This is because with FSA the aliasing is calculated in a separate pass after the rendering of the whole picture is completed.

It solved some of my problems, at the cost of higher rendertimes. Still it might just do the trick for you.